Doorbell doesn't ring

Hi!

We’ve been using our Ring Video Doorbell for a while now, but it suddenly stopped ringing. When someone presses the button, nothing happens. The button doesn’t light up, doesn’t make the ring sound and we don’t get a notification on our phone.

What we already checked/tried:

  • WiFi seems to work fine. From the app, we see the signal is good and we can still use the live view function.

  • Battery is fully charged.

  • Firmware is up to date.

  • Performed a hard reset, using the orange button on the back.

Any ideas on how to solve this problem? Thanks!

Hey @Lisanne91. I appreciate you letting us know what steps you’ve already tried and how it’s worked for you. Since you’ve done the basic troubleshooting and this concern persists, it would be best if you reached out to our support team so they can look into this further for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to report back on what solution they recommend, as it may help other neighbors with a similar concern. :slight_smile: