Doorbell 2 won’t live view or record.

I have 2x doorbell 2’s bought today 1 setup in minutes the other ive installed it over and over the past 4 hours and have got no where? I click on live feed and it just says activating then goes off and asks to reconnect but still no joy?
The one that works is rssi -42 the other is rssi -44 now and again it flashes blue for around 15 seconds. Have also tried factory reset

Hi @Blacky. A great place to start is our Community Post here, which covers common causes for Live View concerns. Since you have already tried a reset and it is still not working properly, you may want to reach out to our support team directly as well. Please give our support team a call at one of the numbers available here. They’ll be able to take a closer look at your device and provide more advanced troubleshooting support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.