Doorbell 2 streaming error

I have good RSSI -46 and good upload and download speeds (20 and 30; respectively) but still have streaming error.
I have tried removing the device and adding it back. Not sure what else to try. Any suggestions appreciated.

Hey @Jomens. Please check out our Community post here, as it details more information on why your Live View may not be loading. Let me know if anything you do here helps! :slight_smile:

I have tried every single one of those options. The app shows that device is there but it is offline and not capturing video. I didn’t change any settings at all anywhere in my house.

I have confirmed the RSSI is good, the upload/download speeds are good, the battery is fully charged, I have tried deleting the camera on the Ring app and adding it back in. The connection from the doorbell to the router is strong, the connection from the phone to the router is strong. I have also tried streaming using my cell service instead of wifi to see, still doesn’t work.

I don’t know why it’s not working, please help me if you can. This is very frustrating :frowning:

@Jomens Thank you for getting back to me and letting me know how this went! My apologises that this was to no avail, but good on you for trying those troubleshooting steps to try to cover this. At this time, it would be best to follow up directly with our support team.

For this support, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know how this goes! :slight_smile: