Door Bell Device not showing on my device list

I have been using my doorbell without any problems. When I open the Ring App, it asks me to get started with Ring by setting up a Ring device. I try to set it up again but it does not let me because my device has already been registered under MY account. I enter in My account but the device does not show up there and the circle starts again, asking me to register the device, and so on… please help!

Hi @sandycassidyrn. You can attempt to remove the app and reinstall it to see if it shows up then! Although, if your device is still not showing up in your app, please reach out to our support team to further assist you in locating it. You can contact them at 1-800-656-1918!

I think I have the same issue. After 3 frustrating days trying to get the internal ding-dong doorbell to work I finally got past that. Now I don’t get motion sensing on my app but can hear the ring chime when the doorbell is pushed. I touch the app icon and I get a screen that tells me to log into my account. When I get into my account it tells me that I need to set up a device. However, I had previously shared the doorbell with my wife’s tablet and she still hears the bell and sees the motion detection but I don’t. Please keep us posted on what you find out.

1 Like

Hi Team,

I recharged my doorbell and now it no longer appears in my device list. When I try to re-register it says already registered but I cannot see it in my account. I had previoulsy shared the device and they could see and hear everything fine. However when I did a hard reset (as suggested in the forum) we have all now lost the device as the master account cannot amend anything.

I am in Australia so time zone to call is difficult now however appreciate anyones assistance as this is my elderly father’s doorbell and we require it for security.

thank you

Hey neighbors! You will need to ensure the device is not a second location if you are not seeing it under your Devices list, but your shared user is. If you go into the Ring app > Main Menu > and then select your location above Dashboard > You should see another location in there, and when you select it and go back into the Main Menu > Devices, the device should show there. If you do not see a duplicate location or do not see the device there, ensure you are logged into the proper Ring account with email address and password. In the chance you still do not find the device in the app, you will need to get in contact with our team here.


Hi Team, tried uninstalling, reinstalling, holding orange button for reset and still not work. Device has now gone offline and we cannot see it in the device list to remove and start set up process over again.

How can we resolve this given the time difference between Aust and USA for voice call?

Any help appreciated as we are at a loss on how to resolve.

Thank you for completing those steps @riac! If your device is still not showing up in your account, and now will not complete a setup, more in-depth troubleshooting may be needed. The best next step will be to reach out to our support team, who is happy to assist by phone! :slight_smile: