Device Health not loading on iOS app

I called into support to report and inquire on the problem. Person I spoke to was very nice and helpful and I fortunately didn’t have to do any unneeded troubleshooting on my end. She indicated Ring is aware of and actively working on the problem. She sent me an email asking I reply back tomorrow if Device Health still doesn’t load. I’ll reply here with any changes as well.

1 Like

I also called support and this time they said exactly the same thing they told you @5150Joel. I think it won’t be long before they fix this. Thanks.

2 Likes

I have the same problem with my hardwired Ring Doorbell 4, plus the battery doesn’t seem to be charging as it did previously. This degradation of r the product through what appears to be a software upgrade is all too familiar a problem with previous Ring products. Looking at alternatives.

I guess I was too optimistic, it has been two days since I talked to customer support and nothing has been fixed. I am getting rather frustrated because I also found out that I can’t answer the ring doorbell.

This is total bs that they still don’t have this fixed and no real updates it seems like a Ring employee on here would give some kind of update

I concur. I talked to support one more time, and even though the person assured me that by the end of the call the problem would be resolved, she was unable to do so. All the person could do was put my name (again) on a list of user who are experiencing this issue. Given how expensive the equipment and services they sell are, they certainly don’t care much for their customer.

Do you @Marley_Ring have any updates? It’s been 2 weeks since I first reported this.

Hi neighbors! We have passed this feedback about the Device Health page not loading onto the appropriate teams so they can look into it. I don’t have any updates to share at this time, but you can contact our support team if you have any further questions. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

We’ve tried calling and they have been zero help this is ridiculous that they could not fix this in over 2 weeks time it seems we are not a priority

I replied back to the email support sent me last Thursday the 2nd. On the 3rd someone replied that they’ve escalated the issue to tier 2 support and that’s the last I’ve heard. I’d love to know how and why this is only affecting some but not all customers and only certain accounts. Not as much as I’d love for them to fix the issue after over 2 weeks though.

Same with me. App been ‘glitchy’ for over a month. First it said an issue with WiFi (all other devices working fine, WiFi rebooted multiple times). Today, no motion detections/rings coming through, can’t access device health, no dashboard showing & can’t access live view. Rebooted WiFi - still no joy. I’ve paid so much money for this equipment - I’ve had so many issues recently. Might as well go back to a door knocker & wired CCTV!

I’ve been having the same problems with device health since around the 23rd of November, I’ve done everything I can and they just won’t connect. I have a doorbell 4 and stickup cam. Hope they get it fixed soon.

We’re nearing the 3 week mark with this problem and still no answers how can that be

I was supposed to get a callback yesterday from customer support, but no one called. I have a feeling that this issue will not be resolved, at least not until there is a major version update of the software, which could take months. This is in the back burner for Ring, since it only affects a handful of users. I am seriously considering dumping all the equipment on eBay and finding a better company for my home security needs. To say that I’m utterly disappointed is a gross understatement.

I agree they seem to have no desire to fix this problem just give us the standard answers without really doing anything to fix it

(This post is not directed to any of the mods here in the Ring Community)

Going on 4 weeks now with no resolution or update. I’ve been with Ring for a fairly long time and I’m still for the most part happy and content with their products.

That said, it’s absolutely atrocious how far downhill their customer support and development have tanked within the past year. I know first hand of other’s having this same issue with Device Health not loading yet Ring support has had people up on ladders, resetting their cameras, resetting their network, all for a problem that wasn’t properly communicated to the support rep; all for a problem that is Ring’s to resolve, not anyone’s phone app, WiFi, router, or camera. Those answering the call have next to zero familiarity with the very products they’re employed to support. Unacceptable. It’s a shame in comparison to how it was years ago when someone capable and competent awaited your call on the other end. Finally, it’s clear very little is tested by Development before a change is introduced, be it the app Device Health, Flood Lights that constantly activate, to an alarm keypad that doesn’t show the current mode when hardwired…just to name a few, but per Support it must be the person’s WiFi…

For what it’s worth I’ve had problems over the years where it was my issue, it was my Wifi. After several years it’s my opinion that Ring products for the most part work very well with sufficient network resources and throughput. Customer support on the other hand is pitiful in comparison to how it once was.

1 Like

We’re sorry to hear you’re having trouble loading the device health for your Ring devices. Rest assured that our team is investigating and working to resolve the issue as soon as possible.

For now it is recommended to check for the following:

  • Try loading the device health from wifi only and then cellular/mobile data only, to see if there is a difference.
  • Reboot your modem/router.

As mentioned above, our support team is always available for further assistance. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

@Marley_Ring, it was determined weeks ago that the problem is not related to the wifi or cellular network, but related to the owner’s account. If my wife, who has a surrogate account, logs in to my device, the device health loads fine, and for me, with the owner’s account, it doesn’t work, no matter which device I login to. I have spoken with at least 3 different customer support specialist who have not being able to help. I was told a week ago, that this problem, which resides squarely at your end, was escalated to tier 2 support. I am at the verge of giving up, and finding another company for my home security needs.

UPDATE: A few hours ago, as suddenly as the problem came, it went away. No call or email from customer support…