Delete All function not working

As of yesterday the “delete all” function on the iOS app is not working and results in a “something went wrong” error message.

App/iOS up to date
iPhone 7

Hi @Tired. Thank you for bringing this to our attention. I will pass this information to the team that works with the IOS. I do have one question, does the History in the Ring app stay in your History? Or is this more of a “visual bug” where it says “something went wrong” but it actually did delete? Thanks, neighbor!

My delete all has not worked for several days. I have deleted and reinstalled the app and it still won’t delete. I get the something went wrong error message too.

Seems like since the last update this feature doesn’t work. It comes up and says something went wrong and you say OK and then everything is still in the history. You have to delete them one at a time which is painstakingly slow.

Hi neighbors! Thanks for sharing your experience with this feature not working as expected. As Tom mentioned, our team has been notified about this. I don’t have any further information to share on this matter at the moment, but thank you for calling this out and clarifying further upon Tom’s questions. :slight_smile:

All verification codes to sign back in show “something wrong”

Having the same issue, but it does seem that items do delete

I also have this issue since the app was updated last week. Video in link of what I am seeing.

History continues to show after delete all and “something is wrong “ message. Close app and reopen, the history is gone.

1 Like

Same thing here. I get the message but just reopen event page again and they’re gone.
I was wondering if I was the only one seeing this. But all in all it IS deleting.

I’m having the same issue. But it IS deleting. Just the message. I can arrow out and back in to the events page and they’re gone.
Prolly another gremlin. Lol.

Still getting same error! How can you not have this fixed by now? Come on Ring!
Too many problems with your cameras, and no one seems to know how to fix them!
Sorry I ever bought Ring cameras. Going back to Arlo, where their service techs seem to know what their doing whenever I needed them. :rage:

It’s a visual bug after the message if you leave history then go back on it’s all erased

As of yesterday with the latest Ring app update all is back to normal on mine.

1 Like

I am also having the same problem with the “delete all” and with the problems having the camera notifications the way I want them (and have them set) and the HUGE length of time it takes for me to be notified that someone is at my door… I wish I’d gone with ATT - and I’m seriously getting close to switching.