DB3 - Swapped out battery, now not functioning

This is becoming a royal pain.

It’s seems that whenever a swap out a charged battery in my Doorbell 3, the device randomly decides if it is going to accept it or not. I have completed this task with absolutely no issue a couple of times.

However, I just tried moments ago and I am no longer able to connect to it.
First attempt, there was absolutely no indication I had changed batteries.
I exchanged old batter for new and back again.
Now, the app shows a fully charged battery, but I still cannot connect to the doorbell.

There is a strong WiFi signal, in fact, I’ve confirmed the doorbell is connected to the router.
Still, there is no connection.

I really don’t think I should have to completely reset the doorbell every time I swap out the battery.

Is there some step to the procedure I’m missing?

Hi @DrSPH. I would only suggest resetting the Doorbell in the instance that it is not accepting a fully-charged battery after you insert it. You should be able to just insert the fully-charged battery and be good after doing so. However, if this is constantly happening, it may indicate something could be wrong with the Doorbell or the battery itself. Would you mind reaching out to our support team regarding this? You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Thanks Caitlyn, it appears I will have to do that.

For the record, I have two batteries, so Ring would never been offline.
In this particular incident, moments after I posted this, full functionality returned … briefly.

I just had someone ring the doorbell and I received the notification as expected.
However, when I attempted to connect, I got the “Activating” and “Connecting” messages and then … nothing.

I checked back through several motion activations for today. Several of the most recent were blank. There were timestamps and associated recordings, but the “video” was just a black screen. Going back to midday, full videos reappeared.

I just activated live view and - voila - the camera turned on.

Given the utter unpredictability of the device, it would strongly suggest IT is the problem.

Was a bit of a hassle needing to call support, but the agent was pleasant and professional and after about 20 - 25 minutes of troubleshooting determined a replacement was warranted.

Will let you know if a new DB3 resolves the issues.

1 Like

Have tried every permutation learned from the service call.
Seems to be an issue with the transfer from the DB3 communicating to my phone and then transitioning to home WiFi.

Keeps dumping me out with an “Something went wrong” error.

Calling support again.

SUCCESS! (I hope)

After >60 minutes on the phone with support, including an escalation to a higher level, had to reset my phone’s network setting to get the Ring to properly connect.

The device underwent an immediate software upgrade once connected so hopefully is now as it should be. Was a bit annoying that I also had to reinstall the app on my laptop to get it properly connected, but now I can get remote notifications wherever my phone is and/or at my desk via my laptop.

1 Like

That was quick.

Am expecting a package today, so was checking Ring pretty frequently.
Both Android and Windows were reacting quickly and well.

And then BOOM -
Now both aren’t working.
Android app was flat out crashing.
Windows would open the dashboard, but not connect to the doorbell.

Well, wait a minute.
While typing, this the Android app came back to life.
And Windows is back.

Guess things are back to “Great device … when it works.”

1 Like

Thank you for updating the Community with the solutions you found to be helpful. As the main resolution looked to have been from altering your mobile device apn settings, perhaps there is a variable there that needs attention. Have you tried reaching out to your mobile carrier/ provider to see if they have any recommendations for streaming on your mobile device. Although, it is odd that you are trying on both Windows and Android devices with similar concerns. Please ensure there is not a vpn enabled during these video connection attempts. Feel free to let us know how this goes! :slight_smile:

Well Marley, today we’re back to both Windows AND Android (Samsung s20 FE) being unable to connect.

Windows shows the “Activating” spinner and then “We’re having trouble connecting to your Ring device.” I’m looking at my phone right now with “Failed to connect”

Aaaand, the doorbell is no longer listed as connected to my router.
(Before we start down the connection rabbit hole again, the router is on the far wall of my living room, the doorbell is on the other side of the living room (outside of course) but it is no more than 15 feet away [and showed a strong signal setting it up].)

There has never been a VPN on my home network and there is not one currently active on my phone.

Just for good measure, I’m charging a spare battery and, next time I’m downstairs, will remove/re-insert the current battery.

This really is the sort of device that becomes useless if it cannot be relied upon to work consistently.

EDIT: In the most ironic of coincidences, in today’s mail (which I didn’t know arrived because, no Ring connection) there was the complimentary color faceplate from Ring. So, I swapped out the faceplates and pulled the battery. The blue light started flashing and as I was putting in the security screw, I heard the familiar chime letting me know I was standing in front of the doorbell.
(For the record, the battery is at 88%.)

Both Android and Windows apps are up and running again.

So, what now?
Do I need to pull the battery every few days to make sure the connection is active?

Hi there, @DrSPH! It sounds like the Ring device needs to be reconnected via the Device Health section in your Ring app. When switching your Video Doorbell battery, this powers down the device momentarily. Upon powering up, it should reconnect to your network automatically, but it some cases it may not. If your Video Doorbell does not seem to be online, follow the steps in this help center article to get it back online.

If your Video Doorbell does not reconnect, or connect with a new setup, our support team can take a more in-depth look for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.