Constant problems after 11 months of doorbell 3

I have a hardwired doorbell 3 that I started using in Feb. 2021. Within the last couple months, it constantly loses WiFi connection even though nothing has changed. Last week, it suddenly said critically low battery (even though it’s hardwired and has never been below 90%). I charged the battery and reset the entire device as it was still saying low battery and couldn’t connect to the WiFi. Finally worked for a few hours last night, and now today again it will not connect to WiFi. I’ve restarted my modem a million times, I have fast connection, and everything else works. This doorbell worked perfectly for about 8 months and now it is constantly off.

I do not have the time or care to take it apart every day and do an entire setup over and over. Is this a bad egg or is there another way to fix it that I’m missing here? I am so frustrated.

During the times when problems occur with connection, check out your RSSI in the device health section of the Ring app, to ensure for optimal wifi signal. If you live in a region where it gets cold, our Help Center article about cold weather and battery drain has some great tips. Please keep in mind, if it gets too cold or extreme low temperatures, this can impact the functionality of your device.

If this concern persists despite bringing the Video Doorbell inside and charging it, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.