Choppy audio on my new Doorbell Pro

So I’ve been battling with ring support and my new doorbell pro for several weeks now to try and get a choppy audio issue solved.

The issue is just when I’m listening to audio from a visitor (they can hear me fine). Their voice drops out with gaps every 2/3 seconds. Sometimes a single drop sometimes multiple in that time.

I’ve tried extenders, mesh Wi-Fi, ubiquit access points, up rating my fibre speeds, ring chime pro you name it.

I’ve also tried tethering my phones data connection and the doorbell is the same, choppy incoming audio.

It’s a little better in the early mornings but never faultless.

Ring say it’s my network but how can that be when I’ve got a strong signal at my doorbell via a mesh Wi-Fi or extender and down up speeds of 108/10mbps.

Also to my mind that argument doesn’t stack when I’ve also tried it on a separate data network (via my mobile).

If I had much hair left I’d have ripped it out by now so I’m reaching out to you guys in the hope someone else has had similar and resolved it?

Many thanks in advance.

Oh I forgot to say, I’m on my third replacement doorbell pro.

Background or wind noise hitting the Ring Pro mic?

Could the Ring Pro speaker be feeding or echoing into the Ring Pro mic?

Maybe there’s some kind of echo/noise cancellation going on.

Many thanks for the reply, here’s an example from this morning, while not dialogue you can hear the drop outs which sounds like stuttering which as you can imagine when dialogue is occurring means you miss pieces of words;

When you do Live View from the Ring app is there a diagonal line across the speaker icon like mine does? (Not sure if that means the speaker/volume is off by default)

  1. Try disabling 2-way talk.

  2. Try plugging in headphones to your mobile device.

  3. Try reducing volume to see if it helps.

Are you using iOS? iPhone? iPad?

(I’m using Android on a phone)

The issue persists on all live view, recordings and devices that view the video. This seems to be the doorbell dropping audio segments (but not the more bandwidth intensive video element of the stream). Ring and I are at a loss to why.

1 Like

Sorry to hear that you’ve had this ongoing experience. While you are very confident in it not being network caused, I would like to add a recommendation to test the Video Doorbell Pro connected to 2.4 Ghz versus 5Ghz, and vice versa, to see if audio improves. Let me know if this helps!

Thanks for the reply.

I’ve tried 2.4 and 5ghz and the result is the same.

I’ve tried my mobile hotspot. Same result.

I’ve had Wi-Fi extenders and mesh products to test. Result is the same.

Following as I too have choppy audio to/from my Doorbell Pro. Somebody in another post suggested a “Reset” of the unit. Somebody else says that did not correct the issue. I have not tried a Reset yet. Have you?

Oh it’s been reset and reinstalled around 30 times as new things were tried. I’ve managed to minimise the issue with a powerline adaptor just two feet from the device. Ridiculous really.

I forgot to mention in my previous post that I used my ipad to test my Internet speed indoors and got a result of 21.3 mbps down and 1.82 mbps up. However, the same test run at/near the doorbell mounted outside on the other side of a brick wall at my front door yields a much poorer result of 2.10 down and only .25 up! There is an outlet inside near that door and I wonder if a Ring Chime/WiFi Extender might help?

I get choppy audio on anything less than 2mbps up so you’ve no chance with .25 up. You need a Wi-Fi booster and I’d suggest powerline as that’s the only thing that improved things for me. I tried chime pro and extenders and mesh etc

Chime pro is rubbish, it made things worse!

Low speeds can cause choppy video and audio on your devices. For the Video Doorbell, we recommend a minimum of 1mbps upload speed at the mounting location. For the Chime Pro to deliver signal the best, it should be placed at the half way point between the router and device while avoiding interfering objects. Check out our Community post on extending Wifi with a Chime Pro.

I still get occasional choppy audio with 8mbps upload speeds and a powerline adaptor 2 feet from the doorbell pro!

Chime pro was setup as per instructions. It’s not good enough and only works on 2.4 which is a congested frequency.

8 mbps definitely sounds like sufficient enough speed for optimal operation. Keep in mind, while the 2.4Ghz frequency is most commonly congested, it also travels much more reliably over distance and through tough interferences. To avoid congestion, I recommend trying different channels on the 2.4Ghz network, and using the 5Ghz network for in home devices, if possible.

1 Like

Ring has never and will not admit it is a problem with their doorbell. Since it was released, there have been complaints with the choppy audio. The problem is with the faulty design of duplexing. Full-duplex audio systems like telephones can create echo, which needs to be removed. Echo occurs when the sound coming out of the speaker, originating from the far end, re-enters the microphone and is sent back to the far end. The sound then reappears at the original source end, but delayed. The doorbell audio keeps switching back and forth, listening mode…talk mode. Hence, the cutting in and out. The speaker and mic are too close together in the doorbell device. Nest doorbells have the same problem. Until Ring admits and redesigns the duplexing, it will not work correctly. And when/if they do fix the problem, we all will be stuck with the old doorbell!


I have exactly the same issue with a brand new Ring Pro, and this analysis makes perfect sense to me…sad!

I’ve been troubleshooting this for over a year.

I’ve had a Doorbell Pro for about 2 years. When I first got it, it worked GREAT. Clean audio and picture. No drop-outs or choppines.

A year ago, Ring contacted me and said there was an issue with my device and they sent me a replacment. Some time after that the choppy audio started, and I’ve had it since. I started a troubleshooting case with Ring around June 2019, and I had a rep stick with me all summer while I tried various troubleshooting. I believe I’ve tried everything a person can try – you name it. The only thing I think haven’t tried is a wi-fi booster like Maniac mentioned. Ring finally sent me another unit, and unfortunately, it’s more of the same.

Funny thing is, I was going through my neighborhood alerts today (videos posted by people within a few miles of me) and MOST of the videos have this same affliction! My gut feeling is: This is a known issue to Ring, so customer service reps simply follow a script and hope you’ll give up. I hope I’m wrong about that.

Another theory I’ve read online are that it was a change in the firmware – the traffic on Ring’s servers was too high so they throttled everyone’s speeds down. Interesting how my firmware only says " Up to Date", so I never know what version I’m on.

Giovanni has an interesting theory; however, my co-worker also has a Doorbell Pro and his audio sounds smooth!?! And… his Firmware version IS displayed in the app. So it’s not happening to every device, which seems to debunk Giovanni’s theory.?

This issue makes communication over the doorbell impossible, so I’m looking for a reliable alternative.

It is strange that one or two may have good audio. However, I still believe it has to do with the duplexing, hardware issue, not software. Don’t tell Ring :slight_smile: but I opened the case of the doorbell to take a look at the circuit board. I found that I am able to reposition the speaker on an angle further away from the microphone. Of course this movement was very slight since it is soldered on the board. Interestingly, it did improve the squeeling/choppy audio slightly. But nothing to write home about. If this test holds true, the doorbells that seem to have good audio could have the speaker and mic each facing a different direction and not into each other. To prove this further, I am thinking of what I can do to isolate the two componets that will fit and not short out the board. Something to simply not allow the incoming audio to point directly into the mic, without removing solder and trying reconfigure and re solder.

Also interesting, today, I was on shift at the fire house. Although I have abviously heard this many times before and never thought much about it, it dawned on me that when I keyed the mic next to someone with a radio, the other radios around me would squeel and echo my voice back after I transmitted. As I thought about it a bit longer, eventhough we have to manually key the mic to talk, the internal componets of the radios are effected electronically by the “feedback”. Hence, the duplexing theory.

Lastly, I opened my cell phone. OK, it was a slow day at the station today! The mic and speaker is in fact shielded from each other and coated with some wax like material. Something the doorbell is not. So, by orders from my wife, the doorbell is reassembled and back outside, but still having audio problems. I am more convinced now about the duplexing problem that both Ring and Nest are experiencing. I could be way off here but so far everything points to this!

I have the same issue with MY Ring Pro. It’s been that way for over a year now. I have tried moving the router (using a long Cable) to the porch right below it and it makes no difference,. needless to say I have spent hours trying all channels and 2.4 or 5GHz.

I have also installed and EERO mesh network since then. This improved other device connections in the farthest parts of our property, but had no effect on the Ring, even though one of the EERO’s is 4 ft away from it behind stucco and sheetrock. I can get a very strong WiFI signal standing in front of the doorbell in the RING app.

I tried the Chime Pro kit. That was DOA and never stopped blinking. I tried everything to get that to work including calling Support. They said that it was unable to connect due to the ANDROID phone I was trying to setup on. I tried both an S9 and an Pixel 3… Same result…

It was clearly a bad unit and I waited too long to return it, to do the install due to health issues in our household…

Unfortunately I have too much invested in this thing to dump it and try a different one.