Chime went offline and doesn't connect to WIFI again

Just recently my Chime has disconnected from WIFI.

I didn’t had any changes on my home network.

I tried to connect it back but it doesn’t work!
I even tried to add a new network with basic SID and password, and it still doesn’t work.

Anyone knows how to fix it?

I must add that I’ve the unit is plugged 1 meters away from the router. So WIFI coverage isn’t an issue.
I tried everything and I couldn’t fix it. It just doesn’t connect to the WIFI.

I assume you unplugged the unit and also tried pushing the button? Is it “talking” to you? There is a voice that says what it is trying to do.

Yes, I’ve pushed the button to reconnect, also tried full reset and setting it as a new device and it didn’t work. And I did those multiple times. I even tried registering it on my wife’s account as a new device and didn’t work either.

It doesn’t “talk” though. It communicates by the LED light modes (on, off, blink fast, blink slow, etc) and the Ring app guides me with the installation. It isn’t a Chime Pro. It’s first gen Chime.

The app connects to the device during the installation, but I can’t connect to the WIFI somehow.

Not sure. I don’t have any experience with the older Chimes. Did phone support have any ideas? Is it still under standard 1 year warranty? If you have the Protect Plus, it will still be under warranty even after a year. I would say give phone support a call and if they can’t solve it, ask for a replacement.