Chime not going into re set mode

Can any one help me get my chime into set up mode please? The ring logo is on but not flashing, I have tried to push re set button for both 5 @ 15 secs bit it won’t going into flashing mode

Hi @Lee22. One other thing you can do is unplug to Chime and remove the “plug” for a few seconds. To do this, safely unplug your Chime and turn it upside down. You’ll then see a button that you can push and simultaneously slide the “plug” portion off of the Chime. Make sure the area is free of debris, then slide them back together and insert the Chime back into your wall outlet. After giving it a minute to reboot, it should then be able to enter Setup Mode.

If these steps do not work, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I have a similar issue. My chime stopped working without reason (noticed that the sound would only come from phone-app and not the Wifi Chime).

First, tried re-connecting through the APP - no improvement

Second, tried to re-enter setup mode (press reset for 5-seconds). The chome would not enter the slow flash (got 3 quick flashes)

Thrisd, tried to full reset (press reset for 15-seconds). Again, only 3 quick flashes. No improvement.

Fourth, tries removing from power and removing the plug at the back of the unit. After several minutes, plugged back in (nothing, retried the above steps, still nothing).


Same here - the Chime went a bit intermittent and now does not work at all.