chime installation not working

We bought a video doorbell 3 + chime, installation went well till we came to the installation of the chime. Chime can’t connect to wifi and light goes from blue to red. We alsi noticed that green light is always going fast while in the app we see that it must be a slow green lignht.We tried several times, also did resets, but still same error. Who can help? Doorbell 3 is installed.


I also have the same problem so if anybody out there knows let us in on it. In setup it says at one point to “with the chime plugged in press setup for 5 seconds then press continue”. I took that to mean the WPS button on my router as it was trying to connect to it but that didn’t work either. The ring app didn’t ask for the routers password so it must remember it from the doorbell installation or else that is the problem.

Hi neighbors! The best next step here will be to remove and reinstall the Ring app on your mobile device. Next, try resetting the Chime by holding the setup button for 20 seconds. Once complete, attempt a setup, ensuring the Chime is nearby the router. If possible, try setup on another mobile device. Please ensure location services are enabled for the RIng app and no vpn is enabled.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.


thanks for the speedy reply. 2 questions before I start your suggestion.

When you say to reinstall the ring app do you mean I would have to reinstall the doorbell device again which is working perfectly?

When you say " try resetting the Chime by holding the setup button for 20 seconds" which setup button are you talking about, there is no setup button on the Chime?

Hi, I have exactly same problem, and I just get something went wrong. Have reset everything including re installing the app. Still won’t connect the chime. Beginning to think this was a waste of money. Any other suggestions???


sorry about that but I foung the reset button on the Chime but it didn’t help. As other people have reinstalled the app without getting the Chime to work I won’t be doing that. It is such a typical help desk answer to reinstall everything without a thought to all the time and effort the customer has. It is obviously an authentication problem. Everything works until it tries to connect with my router. If I don’t get it working this week after loads of attempts I will be sending it back.


found the answer on another post.

When it finds your wifi network answer “NO” when asked if you want to use it.

Then when it finds all your nearby networks choose it again and then it will ask for password.

I told you it was a authentication problem!


I was having the same issue with my Chime, I was about to return the darn thing, but your advice worked. So much for following the instructions.