Changed battery now won't reconnect

Ok so ot the batt low via app. changed out the batt (i bought an extra ring batt) and now it will not reconnect. So to be honest the batt died before I got to change it out. What do I do? I’ve tried manually reconnecting (tells me my password is incorrect, which it is NOT), I’ve done a hard reset and same thing withthe password. I double check my password multiple times, even disconnect the wifi on my laptop and reconnected. My laptop works fine. So confussed please help.


You don’t indicate WHICH battery you “changed”. There are batteries throughout the system.

Hey @Meh! Depending on connection and Ring device type, it should automatically reconnect upon powering up. Please confirm which device you are needing to connect for more specific suggestions. You can also attempt to reconnect the device in the app by visiting the Device Health section for that specific device, and selecting change network or reconnect.

Ok so I have the doorbell 2. My house is not wired for a doorbell, thats why I went with this model. So it did not reconnect automatically whenI put the charge battery in. The app still showed that it had a low batt. Tried to reconnect through the app via device health (as mentioned above). Would not reconnect after multiple tries. So I did a hard reset to see if that fixed the problem and no it did not. Now it is sitting on the table without the batt, and wondering what would be my nex step. sorry for not add which device I had.

@Meh wrote:

I have the doorbell 2…it is sitting on the table without the batt, and wondering what would be my nex step. sorry for not add which device I had.

Not familiar specifically with the “doorbell 2”.

What I can offer is that, in the past, I’ve had similar problems trying to reconnect door and window sensors, for various reasons. The published instructions to open the case, depress the reset button, and insert the battery, and wait for the blinking LED to stop blinking simply never worked.

I found that by using the “Remove” option (in the Android app) to completely remove them from the system, and then, using the “Install New Sensor” process, I was able to get them back online, although it sometimes required a couple of tries. In that situation, when the install instructions called for pulling out the battery tab, I just inserted the battery. If that procedure can be applied to your “doorbell 2”, you might want to try it.

1 Like

so I tried the remove and reinstall and still tells me that have the wrong password. which i know is not the case.

I always used the Android app on my phone for doing these things. You’re doing the same, right?

If it’s a password authentication issue, one thing you could try would be to select the “Forgot Password” option when you log in on the website and reset it. I never ran into any problems logging into the account when I had to do this stuff, but of course, the phone app doesn’t ask for my log in information.

My ring app health area does not show any reconnect option, only offline!!

Having the exact same problem. Did you find a resolution? I can’t figure out how to fix it. Same thing, battery drained and when I charge it now I can’t connect to wifi and it is telling me the password is incorrect.

@keiserross If you are receiving a password is incorrect message, you will need to ensure you are putting in your correct home wifi password. If you continue to get this message, please reach out to our support team here if you’ve ensured you have the correct wifi password.

I’ve been having this EXACT same problem with all of my battery powered devices since I got them over 6 months ago. I have over 35 emails in a thread with customer service and have been on the phone with them numerous times. The last fix seemed the most promising (I setup a guest network on my router to use exclusively for Ring devices), but when I went to change the battery on my device last week, same thing happened… Incorrect password. The funny thing about that is that fact that it was connecting to the guest network that I setup for only my Ring devices, using the “this device was last connected with this wifi. should it connect to the same one?” feature. Still said the password was incorrect. Retyped the password half a dozen times… Still said it was incorrect. Removed the device entirely and tried to start from scratch… Still says the password is incorrect. At this point, the only thing that has worked 100% of the time is changing the password for my router EACH TIME I change the battery. I was hoping the guest network would change that, but I was wrong. With all of the different fixes I’ve been given, none have worked for longer than the charge of 1 battery. Sent my first email to customer service in January and we still can’t figure it out. Probably going to move to another product at this point because it is not worth changing the password to your Wifi network (and having to reconnect each device in your home to the new network) each time you need to change a battery. Let me know if you hear of any other possible fixes.

Sorry to hear you are having so many issues. I got lucky and the first customer service person I talked with had me do a reboot on my router and somehow that fixed the issue. Just a simple reboot of the router worked for me. I had to reinstall the device but no more issues since. I haven’t had to recharge my Ring yet but I’m hoping it won’t happen again. I think the issue the first time was letting it get critically low before charging. Maybe try charging it a little sooner? Good luck!

I also have the ring doorbell 3 (not wired) so bought an extra battery. The same thing happened to me when I changed out the low battery for the charged one it wouldn’t reconnect i tried everything. So I charged up the one that was low battery level put it back in and it reconnected. Im not sure why and don’t understand why but its working.

1 Like

The manual suggests going through the installation process again,

changed batteries now my camera will not reconnect to wifi

As long as these batteries are fully charged, there should certainly be enough power to complete a setup. When troubleshooting a battery-powered Ring device, it’s a great step to bring it inside near the router for a setup or reconnection attempt. Please also ensure the battery has been charged for several hours and that there is no debris in the battery slot.

Another good step is performing a reset, by holding the setup button for 20 seconds. Once this step is complete, please reconnect your Ring device by following the steps in this Help Center article.

If this does not work, or there is no response from your device at all after inserting the battery, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

You can’t possibly be telling us the way to fix the battery powered doorbell that is screwed into the brick on the front of our house is to bring it indoors near the router?
This appears to be a very regular issue, how about posting the real fix so we can stop asking this question?


I have this same issue. Hard reset, rebooted router, tried to reinstall device, forgot network on my phone and reconnected and it still will not connect to the WiFi. I refuse to reset my router password or set up a guest network. Why is this still an issue Ring? Seems like this post is from a year ago. Looks like I will have to call someone which is completely annoying for charging a battery.
After 3 hours of messing with it finally got it back. Nightmare.

1 Like

Ring 2, battery died, would not connect after battery was charged and replaced, no password issue, just would not reconnect.

I tried about 25 times over several days. I finally moved my wifi box closer to the door. Didn’t work. Left it there though. Turned off everything I could that was connected to my wifi Roku was using a lot and I didn’t have it when I originally connected the doorbell. Then I went outside, pushed the button (the one you push to connect it) on the front of the doorbell, held for 20 seconds (hoping for a reset), opened app on my phone, lights were still flashing, started the reconnect process on the app, hit the reconnect on the doorbell again, lights flashed a different color (sorry I can’t remember if the lights were blue or white, but know they were one color and changed to the other color between 20 second hold and the tap to connect while I had the app open), went through the steps, got unable to join a couple of times, hit ok, then the magic occurred! Connected. Know this is a lot, but I did a few things different when it finally connected and I’m not sure which one or all of them fixed it.


Reading this concerns me because I have a Ring Doorbell 2 in battery only configuration. When I pull the battery to recharge it, am I going to have to go through setting this thing up all over again? It doesn’t save the settings?

1 Like