Can't remove Schlage BE469 from app

I had an error while connecting my Schlage lock, and now I can’t remove it. I’ve tried removing failed device, but it won’t work. It says “Unable to remove device”. I’ve also tried removing a Z-Wave device with the lock in discovery mode. That also did not work. Any thoughts are very welcome. Thanks!

Hey @jbye. You have tried all the tricks to get it removed that I was going to offer! Since it still cannot be removed from you trying both those methods, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Just a note that I am having exactly the same problem. I am going to call Ring support as suggested by the one response here, but woefully someone will also post An answer to this problem online.

1 Like

Hey @EdS! Feel free to let us know of any helpful steps or information you find with support. :slight_smile:

I did get the problem solved with the help of Ring telephone tech support.

Here are my notes:

Possible source of problem: Perhaps the Ring repeater/extender was just far enough away and yet close enough to the Schlage lock that it was communicating incompletely: partially but not fully. I have since moved the Ring repeater extender to an outlet closer to the Schlage lock.

Solution: Ring telephone support did a command from their end to remove and forget the device entirely and as part of that process, rebooted my Ring Home Base. We did so with the battery on the Schlage lock disconnected. It is not clear whether or not we could or should have done the same thing leaving the battery connected. However, without the battery connected, the Ring system obviously could not communicate with the Schlage lock and apparently left the lock thinking that it was still connected to the Ring controller. Accordingly, when we reinstalled, it still gave an error message. We uninstalled successfully that time and then reinstalled successfully with everything working fine. An important part of the installation process at that time, however, required that we place the Ring base controller right next to the slide lock to make sure there was excellent wireless communication. To do that, I had to disconnect the ethernet connection and connect to Wi-Fi instead.