Can't login to Win10 App - error code 0x80131500

When trying to log into the Windows 10 app, I get the following message:

Something went wrong :frowning:

The error code is 0x80131500

I’ve tried searching and it appears this code has popped up before relatively recently but only in the context of checking device health. I can’t even login.

Things I have tried but continue to get the same error:

  • Disable two-factor auth

  • Change password

  • Deliberately try an incorrect password

  • Reinstall the Win10 App

The app continues to work on my phone and Mac laptop and I can still login online. It’s just an issue with the Windows app.


1 Like

I’m getting the same error when I try to log in to the app. The app used to always stay logged in on my machine. I just realized today that it hasn’t been notifying me for a few weeks when someone comes to the door, but I get the 0x80131500 error code as I try to log in to the app.

1 Like

Hey neighbors! Please try removing the Ring app, restarting your computer, then reinstall the Ring app. I recommend also disabling VPN and checking for any open windows apps that might be interfering.

Feel free to send a screen shot or example of this error while we share your feedback with our teams here.

1 Like

That worked! Thank you. It’s worth noting that I tried to skip the reboot step with no luck. The reboot in the middle appears to actually matter.

I would assume that since an incorrect password attempt caused the same error and reinstalling the app was a solution that the error code has nothing to do with actually logging in.

I’m experiencing this, as well. I guess when I have time I’ll reinstall it.

More annoyances from Ring, I’ve come to expect this now.

“Hey let’s see who’s at the front door–Oh, darn, I have to login–Oh, darn, it won’t even let me login, let’s waste time researching this problem and reinstalling software”

Ring is absolute pure regret for me because of constant crap like this.


My Win 10 Ring App stopped working with the latest Windows Update around Nov 15. I also can’t log in. I’ve uninstalled, reinstalled app, made changes to firewall, and etc to no avail.


Hey, neighbors! If this concern is persisting despite trying the steps previously mentioned in this thread, it may need a closer look from our support team. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know what you find! :slight_smile:

Having same issues. Tried uninstall, reboot, reinstall to no avail. Thinking it must be something to do with the latest microsoft update as well. I noticed an optional update about the time the app stopped working but have had no luck removing it. I tried a recovery to before the day it was installed but it took so long that when i restarted the computer the next morning, it had seemed to have reinstalled the optional update. Thought I had changed permissions but I guess that didn’t work.

1 Like

I have the same experience. Tried to access my RING ap which previously worked well. Now I keep getting: The error code is 0x80131500.

I have gone through suggested flushes to the app store and cache. I have also uninstalled and reinstalled the app.

1 Like

This solution didn’t work. The app still returns the original error message.

1 Like

I have tried the uninstall/reinstall “solution” and the clear updates and roll back updates. I am still unable to get past the original error code. The app works fine on my cell phone as well as on a desktop machine., It just remains inoperable on my laptop ( a spectrex360 with current software and patches.)



Had the Win ver. working on laptop for a year fine…
Got new laptop, loaded it there…ERROR! 80131500…
Called tech, told to Dload it Not from the windows Store but from RING.Com.
Upon going to, it does not exist,(is not avail there) so given erroneous information.
Call tech a 2nd time, get someone else, who suggests i change my Password…
I was really hesitant to do so, as i didnt think that would fix anything…It DID NOT.
IN FACT…It ended up breaking the APP on my older Laptop as well, which had been working great for a year…and on my phone…So that was TERRIBLE ADVICE!!
Called tech a 3rd time, and escalated to someone that actually knew something, got a guy that was actually very nice and knowledgable…a Brendon,Brandon or some such…He told me they will no longer be supporting the WIN10 app as of sometime in
2021…They’re going to a Web based version, which, Although, has more features,being able to arm disarm as in the phone app, etc…Basically needs QUITE ABIT OF WORK…and Frankly SukS! at the moment.
1)Your Maximize view has no SLider Bar or pause buton (s) avail…
2) Managing (i.e deleting etc) videos is a nightmare…you have to click a seperate
“manage videos” link, then when trying to batch delete, the whole view of video selection sputters in and out, then disappears COMPLETELY??? basically have to delete one at a time in viewing section…The web version could be nice if they Get it Working Correctly


I bought a Ring starter pack this week with two extra cameras, and was really hoping to be able to use the windows app on my pc as my main viewing station.
I installed in on my windows pc AND my windows laptop (both with different specs etc) and both suffer from the exact same problem - five days on, neither have signed in even once.

I looked online and kept seeing the same sequence of ‘solutions’ on page after page, but after the umpteenth reinstall to BOTH machines I’ve given up. It’s clear they are not bothered with the windows app, and the fact that they are/have limited functionality on the app anyway is proof of that.

Thankfully I have an android phone and things work on that, but it is not ideal as I need the phone clear for other work-related things. What a disappointment.


I just found out about the desktop app tonight while researching a different issue I’m having (chime pro refuses to connect to my IOT network instead of the main network) and I also cannot log in. Brand new install, never had it before, errors out. I only see the Microsoft store as an app download option, which sucks too.

that didn’t work

There’s been a lot of activity over the past couple weeks. Mine has also stopped working and the previous (annoying) steps to fix don’t work.

Clearly the latest update broke something. Why isn’t the version rolled back until the software can be fixed?

Why do I pay a subscription for a product that gets worse with updates?

I have the same error code. Spent over 2 hours on the phone yesterday trying to get it figured out. Tried all the steps above, nothing worked.

Cannot login to ring app on windows 10. Same error. Have tried to reinstall, restart, close all other apps.

It’s been over a week since I first tried, and in that time they had an issue a few days ago that took the service down for several hours - so my first experiences with Ring have been a bit disastrous tbh. I wss burgled a few weeks ago and this was supposed to be my efficient response to the situation, but it just hasn’t worked out the way I had hoped.

Same annoying issue. Plus RING technicians say different things. One was just saying it’s Window’s issue, so call Windows tech support and not us. Very rude. Other was keep changing his mind about the Win10 app no longer supported by Windows 10. He had no idea and learning about it as we go and the app doesn’t work since Nov 11. RING GET YOUR CRAP TOGETHER. I pay for a service and now I can’t have a live view on my PC so I have no idea what’s going on on my yard. Now what I’m paying for !!!