Can't log on to ring.com via my home router's public IP address

OK, odd problem. Recently I noticed that I was unable to log onto my ring.com account from my laptop. Kept getting an error saying my email or password was invalid. Couldn’t log on from my phone, either, or from two other desktops in my house. Changed passwords, cleared cache, tried a different browser, rebooted my router, etc etc. This doesn’t have anything to do with the app, I was trying to log on to ring.com from a browser on these devices.

Then yesterday I noticed that if I turned off wifi on my phone and used cellular data, I could log on. Then I tried tethering my laptop to my phone (rather than using my home network) and again, I could log on.

So…this led me to try again with the laptop, but using a vpn service to appear to ring.com as if I was at a different IP address. It worked.

For some reason, any device that I use is unable to log on to ring.com when using the wan public IP address in my router (Frontier Communication is my ISP). Does ring.com have a blacklist of IP addresses that I somehow wound up on? Is there any way to further troubleshoot or otherwise correct the issue?

Thanks for any help.

Hey @lakemirror. Thank you so much for bringing this up! Your hunch is correct. As of December 2019, we no longer support the use of VPNs while accessing Ring.com, the Ring app, the Rapid Ring app, or Neighbors applications. In order to use these applications, users will need to disable their VPN or ask their VPN provider to help them exclude Ring traffic from the VPN. I recommend reaching out to your ISP or the VPN service you have to see if they can help you exclude Ring traffic while having your VPN enabled! This should help with the mobile app experience more than anything. :slight_smile:

Thanks very much for the rapid response! However, that’s not quite what my problem is.

I CAN log on while using VPN (I use NordVPN). I can also log on when bypassing my router’s assigned public IP address on my phone by disabling wifi and using cellular data instead.

So…the issue is not vpn. The issue is that ring.com won’t accept a login when I present using the public IP address that my router assigns. I don’t want to show my IP address here, could I PM it to you and ask that you find out why I’m unable to log in when using it?

Again, thanks very much.

Tom

@lakemirror My apologizes for getting confused! That is indeed odd, but it’s possible NordVPN is making an IP address that Ring does allow (a country we’re supported in). It seems to indeed by about the public IP address. If you can, please email chelsea@ring.com with your information and I can follow up with you accordingly. It may take some time to get back to you, but I’m sure I can have an answer for you by tomorrow. :slight_smile:

Will do, and thanks

1 Like

Hi,

I’m experiencing the same issue. It seems that my home IP address is locked on ring’s servers.

Did you manage to fix the problem ?

Thank you

My issue has been resolved, although I have no idea what transpired. Chelsea with Ring sent me a very detailed list of things to try and was very helpful. When I started to troubleshoot based on her suggestions, I went to ring.com and suddenly was able to log in again (had not tried since first posting here)

So, I have no idea why I wasn’t able to log on in the first place, and even less of an idea why I’m able to now. It sure seems to me that it was an issue with my ip address, but my address hasn’t changed (I checked) and now it works. Gremlins.

Thanks, Chelsea.

1 Like

I am of all a sudden having this same issue since yesterday. I talked to a customer support representative who collected my public IP address in order to fix this. He told me to expect and an email shortly, but I didn’t hear back. Interestingly, this started at the same time I upgraded my account to the Protect Plus plan. As with the others, I can connect through my cellular connection, but as soon as I go through my home network/wifi, I am blocked.

I had exactly the same odd issue. I can no longer login from my ISP’s public address, and I now have to use VPN to login. And oddly enough, this started to happen right after I upgrade my account to Protect Plus plan too. I’m so disappointed with Ring service

Hi neighbors. If you are having this issue, I would suggest reaching out to our support team. They will be able to collect some information from you and hopefully be able to provide a resolution.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.