Can't log in on 3 separate computers (0x80131500 error)

I have 2 desktop computers and 1 laptop, all using Windows 10, and I can’t log on. I get the 0x80131500 error. I can type in wrong log in info and I still get this error, so it isn’t a password thing. I’ve looked this error up and this seems to happen to a lot of people. People have suggested that if you uninstall Ring, then reboot computer, then download Ring again it’ll work. That hasn’t worked for me and I tried on 3 different computers. I can use Ring on my phone though.

Any help would be greatly appreciated.

Hi @GF14. There is something you can try here. Try connecting your computer to a wifi hopspot. Once connected, see if you’re able to login. If so, there may be some firewall settings on your original network that need to be adjusted. If not, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. I hope this helps!

I have also had this problem. Ring will work on my phone, but I can’t log in on 3 separate computers! I get that error. I too have tried all the steps previously listed.