Can't get security screws off!

Hey neighbors! If the suggestions recommended in this thread were not helpful in removing the security screws from your device, please give our support team a call at one of the numbers availablehere. They’ll be able to take a closer look at the options available for you. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support.

I am one of the early birds of ring products. I have the 1st gen ring doorbell which I installed 2.5 years ago. My wifi settings changed so i needed to update it on ring. The only way to do this is to press the orange reset button on the back of the device. Of course both the security screws at the bottom were not coming off. The screw heads were not stripped, instead the metal screw inserts that’s molded into the plastic housing were stripped. Used brute force to rip away the aluminum face plate in hopes of just popping it off, but soon realized that the 1st gen ring doorbels do not have removable faceplate. After a his i used pliers to pull out the screws. They both came off with metal inserts and some damage to the housing. After this iI popped the while unit off the mounting bracket, reset the wifi setting and just put it back without any cover plate. I used some electric tape to cover some exposed components and no security screws!

I called support before resorting to destructive method, they suggested to upgrade to $9.99/mo plan which will cover device replacement warranty. Second option was a 35% off coupon to buy a new door bell of choice. Was not pleased with either option and this is a design flaw and the doorbell was used as normally ad possible!

I am surprised to hear that the same issue is happening on newer models of the doorbell.

Using a small Flathead between the ring doorbell and the plastic screwed into the wall and then twisting the flathead worked awesome. The doorbell piece popped right off

2 Likes

That is exactly what working for me. I used a very small flathead screwdriver. I started on the right side and carefully pried the plastic cover away from the unit. Then I moved to the left. Once I had enough away from the doorbell it popped off. The cover and battery as one. I was able to turn the battery inside the cover and get the screw to come loose. Nothing broke and now I can charge the battery. I put some Vaseline on the screw so hopefully this doesn’t happen again. Not sure why I have to keep charging the battery when I have it hardwired?!?

1 Like

Your wife was right. Use a eyeglass screwdriver to apply a little pressure downward on the screw through the rectangular space. Then screw off with a screwdriver. You’ll get a little bit of space, slip an exacto knife between the screw head and the case. Then finish screwing and you can get it out.

Maybe use a dab of JB Weld on the nut, to hold it in place for the future, once you get it off.

Beyond mad!
Can’t get screws off! Just spin in place
Black faceplate won’t budge
Countless attempts since aug 10

1 Like

Thank GOD for this post and all the replies! Same thing just happened to mine after a 6 day heatwave in London. Temp was up to 37c and I am sure it must have melted the screw. I think I must have been lucky it was only on one side… I followed advice from one of the replies here and used a small flathead screwdriver which I inserted between the unit and the backplate and it just popped off really easily. So now it is charging, but I don’t know if it will go back on easily with the one screw still stick right in. Sorry Ring but this is my second unit (the first one simply wouldn’t hold charge for longer than about 6 days!) and I NEED all my cameras working at all times as I am at continuous risk of domestic abuse! You simply HAVE to sort all these problems out, as I explained to the customer service lady on the phone before, people’s lives depend on these units so you can’t afford to mess up like this. PLEASE SORT IT OUT! Thanks.

1 Like

I have to add to the dogpile. The head on the screw seems to need some sort of tool that I’ve never seen, a torx 15 or so with a hollow point. I ended up using a long nose pliers to grip and screw it in place. Thankfully I have power to the doorbell and won’t have to remove the battery to charge it.

FYI. The screw driver comes with the unit. It’s needed to install and you can get one for like $2 from Ring if needed. A bit from a hardware store is also easy to find.

1 Like

This is a ring design flaw. They should pay for a replacement after we break it off.

1 Like

It takes T6 Torx driver to get the little screws out. The head was stripped on one side so I couldn’t remove it.

Used a pair of needle nose pliers heald at 90 degrees to the screw head and managed to loosen it enough for wrench to work. Someone else suggested this above. It works for stripped torx heads.

1 Like

Yes same here. I have three 1st gen Ring door bells, three Ring Pro door bells and one new Ring door bell 2. All three 1st gen Ring door bells security screw have sized. The brass insert is either in the plastic spinning or have come off with the sized screw. All three also have their night time night vision lighting dead. All I see now is pitch black. I took one out and replaced it with a Ring door bell 2 (with the removable battery).

Did you guys replace your door bells with a newer model? Or have you gone to another vendor? I have two doors left with the original 1st gen Ring I’m looking to replace.

I need to reset my WiFi and don’t have the tool that came with Ring. How can I do this?

I believe it is a T6 hex, but google should help you confirm that.

Amazon sells them as well as other sites. Just google “ring screw driver”

I had one screw that was working and another that was not, until the 2nd screw went out today.

Since I could no longer remove the doorbell camera to charge it I was extremely frustrated and upset. I called the 800 # and they were super helpful. They ended up sending me a replacement one for free and said that I am not liable for any damages I might cause taking the old one off. So very grateful for their customer service.

I recommend calling them before trying to remove it yourself to avoid breaking it before speaking with them.

I had the same problem. Just talked with Ring support and here’s what worked. I had first loosened the one screw that still worked, but hopefully this works for those of you who have 2 stripped screws.

Get a rubber mallet. Place towel over the top and hit the doorbell casing, but not very hard. Then place the towel over the bottom and hit the doorbell casing with a bit more force. It came right off with no damage to the casing.

1 Like

Remember the supplied screw driver is double ended !

1 Like

@sudschetty wrote:

No luck with knives/blades etc… however if you take a small thin screwdriver and twist in-between the backplate and ring device - it pops out of the holder really easily!!! Nothing broke so far (hopefully…) but this is pretty terrible quality…

Thank you - this worked for me. As you say, terrible quality…

If spinning in place…anyone tried eyelash tweezers ? .