Cannot post to Neighbors

I cannot post a video of a theft in my ring app. I keep getting the same error : non baseline avc video not supported. How do I post the video??
It’s .mp4 format. Thanks.

Hi @ChiNeighbor000. Could you try posting this again after ensuring that you have a stable connection to the app? You can also try removing the Ring app from your phone, rebooting your phone and then reinstalling the app. From there, let me know if this still is happening with a screenshot of this error message so I can take a deeper look into this!

Hello,
I still can’t post. The error is still there. I’m going to try and upload to YouTube. Thanks

1 Like

@ChiNeighbor000 What video format is it in? MP4 usually is good as long as the video size isn’t too large/long as well. You can also try uploading to Youtube and then sharing the link with your post on the Neighbors app!

I’m having the exact same issue. Pretty irritating.

Hey @httpJared! What file size is your video? Please ensure that the video is a MP4 format and less than 200mb to have a smooth uploading. You will also want to make sure you are following the guidelines for the Neighbors app when posting. :slight_smile:

Hi, the file I am uploading is under 170kb,and in MP4 format it is from a blink camera and I tried converting it in case it was something from the original downloaded format but still didn’t work.

@httpJared What error message do you get when you try to upload the video? If you can, please post a screenshot of this message so I can take a look into this!

Here’s the message. Thank you for replying so quick. Really appreciate it. ?

@httpJared Thank you for that screenshot! Although it may seem like the video file is a MP4, there must be some information in the file format that makes it maybe a version of MP4 without being a compatible MP4. I recommend to try to upload this to youtube, and then maybe link out to the video from there. I apologize for this hiccup in the meantime! I’ll make sure to pass on this experience to the appropriate team for you to be looked into further for future. :slight_smile:

1 Like

Use FFMPEG to convert the video into an acceptable format for the Neighbors App.

ffmpeg -i in_video.mp4 -vcodec libx264 -g 16 -r 29.97 -acodec aac -b:a 256k -vf scale=1280:720 -profile:v baseline out_video.mp4Use FFMPEG to convert the video to an acceptable format the command is:

I am also seeing this “invalid file format” issue when I try to post a Blink Camera video. Why should I have to transcode the file into a different format? Souldn’t this integration just work? Aren’t you part of the same company now?

Amazon owns both but they are still separate. So that’s most likely why it can’t be brought to the neighbors app unless converted.

I’m having same issue, it’s an mp4 file also from a blink camera. It tells me that it is not in mp4 format, in which it is!

I ahve the same problem no one at ring knows why

My post all say upload successful but they never appear, and nothing shows up in my posts