Cannot login to

I have been unable to login to for several days. My ability to log in via the app is unaffected. I’ve changed my password multiple times via the app (when I try to do it on the site, it gives me a 404 error) and called support and I’ve been told that the web site is having issues but my wife and other friends are able to login with no issues. I keep getting a message that says “invalid email or password,” but I receive an email confirming the login with the device and IP. I’ve tried multiple devices and browsers.

Any assistance would be appreciated.

Ring status doesn’t show any recent or ongoing email issues. Last time was on 9-11or 9-12.
You can always check Ring’s status here.
I would definitely clear the cache from your browser and reboot. Then try to log in again. Also, are you using the correct password? And you’re trying to get to just only? A 404 error would mean that page on the site is missing usually.

Yep, I’ve been checking the status site. I’ve cleared cache, rebooted and tried to log in via four different devices and three different browsers. is the issue (but I can log in to these forums, obviously)–the app logs me in and works perfectly. But I cannot log in to change my billing info, permit info, etc.

Have you tried it on wifi and data as well? I can’t think of anything else to try. It’s very strange.

Hey @Jd8499! It looks like you’ve covered all the right steps here. If trying a different connection method or checking for an enabled vpn does not help, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes! :slight_smile: