Cannot deselect Echo device in iOS Alexa App for Ring Notifications

I was excited to see that you can link Echo devices to various Ring devices for Motion or doorbell notifications. I setup per Ring instructions, this worked but went to EVERY Echo device and I have 9. I then went to Announcements Devices for the Ring device in the Alexa app and when I deselect one or more devices, I get a Red Error banner at the top of the iPhone “Something Went Wrong”. I tried single devices and a group by unchecking and then hitting the back arros and I get the Red Warning. After 6 or more attempts, it did remove one of my firestick devices but attempts to remove others fail.

Hi @Brumey. It sounds like there could be an issue with the Alexa App not allowing you to deselect an Echo device. I’d recommend uninstalling the Alexa App, restarting your phone to clear the cache, and reinstalling the Alexa App. Let me know if that does the trick for you! :slight_smile:

Restarted phone - Same Issue

Uninstalled and reinstalled Alexa App - Same Issue

Red Error on top of screen after deselecting a device from a Ring Announcements menu. iOS app seems to be broken.

Whant me to uninstall and reinstall 3 times? Joking. This needs to go to the app developers for a fix.

@Brumey Thanks for letting me know what you’ve tried. The only other step I can suggest is to remove and re-enable the Ring Skill in the Alexa App. If that doesn’t fix this concern, then you’ll want to contact Amazon Alexa’s support team directly at 1-877-375-9365 for further troubleshooting help.