Can’t remove Schlage lock

Setting up our new Ring alarm and tried to add our Schlage lock. Entered the wrong pin the first time so it ended up being listed as a device but didn’t work. Went through the process to remove it and the process completed successfully but the lock is still listed. I went ahead and added it again with the correct pin and it’s now working. Unfortunately I still have a broken device added. What are my options at this point?

Hey @thaueisen. If you go into the Ring app > Main Menu > Devices > Alarm Base Station > Lock that isn’t working > Gear icon at the top right > Advanced Options, do you have an option for “Remove Failed Device”? This will help remove devices that don’t remove with the normal “Remove Device.” If this fails too, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know how this goes! :slight_smile:

Hi Chelsea,

I did try that before adding the second time and it did the same thing. The lock gave me the green check mark, saying it completed sucessfully but the lock didn’t dissapear from the app. I’ll call support when I have some time to kill :slight_smile:

1 Like

@thaueisen Sounds good and thanks for confirming that! Let me know how they get that sorted out for you when you have the time. :slight_smile: