Can’t Live view

All of a sudden today I can’t live view on any one of three devices. Nothing is wrong with my internet, it’s fast about 30mbps. I reset the modem and router just to be sure. It is recording motion and I can view the event just not live. Device health all says ok, firmware all says up to date. I tried reinstalling the ap. I tried on my phone and ipad on two different wifi networks and cellular. Same streaming error. It’s worked fine for 1 to 3 years depending on the device and now nothing,

Hi @Libsdr. Has your internet service provider made any changes or upgrades to your network? As a test, try connecting one of your cameras to a wifi hotspot. Once connected, try to pull up the Live View. If it works, this will let you know you that some configurations on your home network need to be made. Let me know how this goes!

I have the same problem on a Xiaomi MI 11 Lite phone. Was working perfectly last week and it seems there was an update to Live view. Now when I try to connect to live view I get “Failed to connect” within about 2 seconds. Viewing of captured video is fine and the app still works fine on my old company Iphone 8. Tried uninstall/re-install of Ring app and cleared all data/cache but still the same. From advice on this forum, I tried installing “Rapid Ring” app. This surprisingly works fine for Live view but more of a work around than a solution.

2 Likes