Bug Report: Doorbell Pro doesn't properly failover to secondary DNS server

If your network is configured to handout multiple DNS servers, it appears that the ring pro (potentially other models as well) will only use the first DNS entry that is given out by DHCP and will not failover to the 2nd or 3rd DNS server entry like it is supposed to. It will then think it fails to connect to your wifi, even though it does connect correctly.

After spending several hours with chat support, getting a replacement unit, and installing I was finally able to track down the issue. As it turns out, my primary DNS server (pi-hole) was down and I didn’t realize it, but all the other devices in my house failed over gracefully to my secondary DNS entry like they are supposed to so I didn’t realize it. After swapping to the primary DNS in my DHCP server the ring was able to connect and started working again confirming this.

This seems like an oversight somewhere in the firmware networking code. Every other computer, smart device, smart tv, tablet, phone and camera in my home gracefully failed over to the secondary DNS server except for Ring. On the plus side it helped me realize my Pi-Hole was offline and not blocking ads. Hopefully this helps someone else trying to troubleshoot and maybe someone on the dev team will see this!

1 Like

I had exactly the same issue.

Two DNS servers in the DHCP scope that the Ring Door Bell was trying to connect to. The primary one was down and although I could see the Pro had an IP address it said it could not connect to the internet. I spent ages trying to get it to connect.

I set up a second WiFi SSID and fortunatley choose the working DNS server as the primary, everything worked straight away.

Just to prove it I swapped over the DNS servers in the origional WiFi scope and connected the Ring Pro to that again. This time it worked straight away.

Swapping the DNS servers again with the broken server first broke the Ring Pros internt connectivity.

So there is deffinetly something wrong with the way the Ring Pro handles failing over to a secondary DNS server.

Confirmed here. ARP request for primary DNS server non stop even when it’s down and secondary DNS server up and working.

Hilarious, it can’t use a secondary DNS server, basic networking 101 guys.

This is almost a deal breaker, sell on ebay, buy Unifi cams then I suppose.

I suppose the solution is a dedicated wireless SSID with just 1 DNS server (not pihole)

Not really.

Just accept the fact that if your primary server went down then Ring may stop working. No point in restricting an SSID to one DNS, you would just end up in the same situation. If your single DNS server went down then you are not going toresolve anything. However if you continue to use two thenm assuming that the competant :smiley: company that Ring are you will be able to use the two without changing anything. I wouldn’t hold my breath though.

I know this won’t help you but I am curious. How did you create a failover DNS? I currently have a second router using google dns that I transition to if pi-hole fails. I use an archer a2300 as my main router.

In my case, I got my ring before installing pi hole, then switched over to pi hole. I restarted my router multiple times, but it was stuck on google DNS.

You just have a primary and secondary DNS Server IP Address. If you are using DHCP then you just put in one IP Address in as the Primary and then a different IP Address for the secondary. If the primary DNS server goes down then your client should automatically fail over to using the secondary DNS to resove addresses.

In my case the Ring did not move on to the secondary DNS server for what ever reason, even though all of my other clients did. It was stuck using the first IP Address for DNS that my DHCP server gave it.

1 Like