Brand new device, Boot Loop (Gen 2)

Hi Guys,

Brand new Device delivered today, trying to set it up and it seems to have failed on the firmware update, now the device seems to be stuck in a boot loop, I’ve spent about 3 hours trying to reset and run the set up again which works however, live view doesn’t work, it just shows “activating device” and has done for the past hour or 2 I’ve left it.

I’ve noticed the door bell flashes blue (1 Second On – 1 Second Off) constantly, when I press the doorbell button nothing happens, Alexa sees the device so does my phone but nothing works.

I’ve tried the set up on two different phones, 1 iPhone and 1 Samsung, both do the same thing, unfortunately support is closed even though it states 8am till 8pm…

Have I got a faulty device?
i am no means a novice when it comes to tech and the like so i don’t believe this is an error I’ve made.



We’re here to help, @MattHenty! Thank you for sharing your observations in detail. The update failing sounds like the initiation of this loop, so lets start a new setup and try an update again. Before attempting another setup, please perform a reset on your Video Doorbell. To do this, hold the setup button for 20 seconds.

Upon completing the reset, try a new setup in your Ring app on any of your mobile devices. This should complete successfully, and update should complete as intended. I recommend performing this setup/ update in the same room as your wifi router. I hope this helps! :slight_smile:

Evening Marley,

The tech support guys did try all sorts to get the device back, they managed to get it to ring, however the camera would not work, and they’ve sent me a replacement out which came the next day.

Great service.

Thanks for your reply


1 Like


Hi’ Ring Support

I suffer exactly the same issue as described here.

But when I contacted your support yesterday, the supporter insisted to send me a Pro power kit v2, I asked specifically what the little box (PPK v2) exactly was or would contain. The answer was, ‘nothing, it contains nothing’, I asked if he was sure that it didn’t contain a fuse or something similar, where to the answer was ‘no’.

But still this empty magic box would definitely solve my issues?

I think not, and now I have to wait for the ‘magic box’ to arrive with postal carrier within 10 working days according to your support, and I can only hope that it will land at my step as he got my address (house number) wrong :frowning:

So my thoughts after reading, first what the PPK v2 is, this is an automatic and intelligent fuse box, no more, it has no features to control the AC outlet V nor Amps etc. so please explain to me how this is going to solve my problems with the flashing lift (blue in the upper half), I can’t enter setup mode. Everything has been tried, hard reset, disabling power for more than 12 hours.

The device have been up and running no problems, but suddenly it kept going offline. It’s connected directly to the following power supply from the Ring doorbell Pro box which is connected directly to 220V on the house powergrid and of course connected with new wires directly to the doorbell.

I have measured the voltage output which is just above 29V, which according to the supporter was wrong, but he still insisted that the PPK v2 would solve my issues, I’m not convinced, can you guys please convince me that I’m not waiting in vain?

Please assist me ?