Battery won't complete charging

I have a stick up camera battery - less than a year old and has worked pretty flawlessly. Got the battery low notification for perhaps only the 2nd or 3rd time the other day so removed the battery and put it on charge. Orange & green lights lit up as normal… but it never reverted to just green to indicate fully charged. I left it the whole weekend then tried putting it back in the camera. Device Healthcheck showed 4% charge and Live view disabled. Changed cable, plug and socket to all known good kit, put back on charge and left for another 4-5 hours. Same two lights. Back in the camera - 2% battery. Is there a trick to get the battery to charge properly? It’s less than a year old and has only been charged a couple of times so should be plenty of life in the battery.

Hi there, @ringring20! It sounds like you are doing everything correctly. As long as you’ve charged your battery for several hours, it should certainly be sufficiently charged. Although the battery level does not reflect as charged in your Ring app, try leaving the battery in for some time and trigger a few motion events, to see if the battery level will eventually register and update. Feel free to let us know how this goes! :slight_smile:

1 Like

Thanks @Marley_Ring. I left it charging overnight (8hrs or so) then put the battery back in the camera. It did trigger a couple of motion events straight away, but battery was only 4% then dropped to 3% and won’t trigger any motion events now. Anything else to try next?

Sounds like one or both of the cells in the battery pack are bad. I had a similar thing happen with the second battery pack I use in my solar floodlight. I contacted support and they’re sending me a replacement battery pack for free.

1 Like