battery charged ring doorbell says it ist

Can’t reset or delete to reinstall says battery flat…its fully charged. Any ideas. In Ireland

Hi @Foreversky! If you are certain that your Doorbell received a charge for several hours, using the USB and a standard outlet, your Video Doorbell should certainly be working. To perform a full reset please hold the setup button for 20 seconds. Once you complete the reset, please perform a new setup process in the Ring app. This should result in your Doorbell connecting and functioning as intended.

Try also, charging the device using a different USB or plug outlet to see if this improves the power. I hope this helps! :slight_smile:

Tried battery different cable , charged green light come on.cant resest .because it says battery is low…have ordered a new battery wont be here til next week…ring is less than yr old…

That is odd to hear of, @Foreversky. Please let us know if the new battery resolves these concerns. We’re here to help if needed! :slight_smile:

New battery worked?glad it wast ring doorbell itself…that wud have been fun to resolve ?

1 Like