App stopped working

My Ring app has worked fine for a year and now all of a sudden it no longer functions. I deleted the app, re-downloaded it and tried to sign in but it constantly tells me "an error occurred. " I AM able to sign in on the computer using the website and my sign in information. I cannot use that sign in on the app. It also won’t let me set up a new account because it says I already have one. I feel like I’m running in circles and cannot figure out how to make the app work again. Nothing I’ve done allows me to sign into the app on my iPhone. Please help.

Hi there, @jannekeb! The Ring app should certainly allow for you to log on, especially if your credentials are working on via web browser. Please ensure there is not a vpn enabled on your mobile device and that your IOS version is IOS 11.0 or later. If you have another mobile device available, try logging in on that as a test. Feel free to let us know how this goes! :slight_smile:

I did the suggested internet speed check and everything is good but my live still won’t work. This all used to work perfectly but now I can’t ever access my dashboard and live never works. I don’t want to keep paying for something that isn’t working. I don’t get notifications on my Apple Watch like I used to and nothing on my phone app works. At this point, it’s just a fancy doorbell and nothing more.

I have IOS 14.1 and internet speed is fine. I Don’t understand why my app on my iPhone 11 no longer works. All I ever get is a message that says, “Couldn’t load your locations.” Re-Trying doesn’t help. I am able to get my dashboard on the computer so there’s a disconnect between the app on my phone and the information from Ring. I am due to renew next month and if this isn’t resolved I won’t want to renew. It doesn’t do me much good on my computer. I need it on my phone. Please tell me what I need to do. I have restarted the phone numerous times so that isn’t the solution. Why did it work before and now it’s stopped???

Hi, @jannekeb! Do you have many Ring devices or locations connected to this Ring app? The Ring app should certainly be loading as intended, as long as the newest app version is installed on the latest OS, and there is no vpn enabled on your mobile device. As a test, please see if your Ring app will load more efficiently with only wifi connected on your mobile device, as well as with only cellular data, to see which connection is optimal.

On your mobile device please visit your IOS settings menu, then scroll down until you find the Ring app. Tapping on the Ring app in your IOS settings menu will display app permissions , in which you’ll want these enabled for the Ring app to operate as intended. Alternatively, try out the Rapid Ring app as it is designed to provide quick access to live view and is naturally less robust of an app.

If the above steps do not lead to improved app functionality, this may require a closer look from our support team. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to keep us updated on any solutions you find! :slight_smile:

I had the same problem yesterday after I reloaded the app on my phone. The app worked on my iPad just fine so could not understand the problem. Thanks to you I solved the problem just now by turning off the Norton VPN.