All Ring Devices Refusing to Connect

Howdy folks,

For the past few days I’ve been struggling trying to figure out why every single one of my ring devices, including the chime, are all unable to suddenly connect to the internet. I’ve hard reset everything back to “Setup Mode” and reconfigured the WiFi settings down to a very simple setup (though the past configs worked just fine), i’ve completely removed my hardware firewall from the equation, I’m just out of ideas at this point.

I just get stuck in a loop in “Setup Mode”. The device displays an error code (blinky lights, circle flashing, etc.) and then reboots into setup mode.

In particular for this purpose, my main concern is the Peephole Camera Doorbell that I use to watch for deliveries and such. Though this is EVERY device I’ve got. Stickams, Chimes, etc. Everything else on the wireless network is just fine. Smart TV, game consoles, cellphones, computers, etc. It’s JUST the Ring devices that are unable to connect.

Anybody got any ideas?

Hi @TheDaoistTech. It’s definitely odd that it’s happening to only your Ring devices, and is happening to all of them. One thing you may want to check are the ports and protocols on your router, as certain ones are utilized by Ring devices and they may need to be opened in order for your Ring devices to be reconnected to your wifi network. If that doesn’t do the trick, our support team can help you take a deeper look into this.

You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to report back on what solution works for you or what our support team recommends. :slight_smile:

Howdy Caitlyn!

Grab some popcorn cause this one gets quirky.

So I double checked my firewall rules, NAT Forwards, Triggers, etc. etc. and all of the required ports are being forwarded outbound along with correlated rules to their aliases to allow protocols leaving my LAN and for LAN devices to chatter across. Remember that word ‘alias’ cause it’s important. So I ran more testing with one of the stickcams I have. Few packet captures later along with a few log dumps I’m seeing DNS handshakes reach out from the Ring devices but getting dead-air in return. So mucking around with my DNS centric rules, I started finagling around as a sanity check and Lo and behold I think I’ve discovered a bug in the firewall firmware.

The firewall has an “alias” function which allows me to setup multiple IP addresses, Port numbers, identities, etc. under a single ‘alias’ that I can use to optimize rule creation. No need to create a rule for every single triggered/forwarded port or handful of IP addresses. Just bunch them up under an alias and write a single rule to apply across the group. Well for some reason that… stopped? Broke? I’m not getting any errors in any of the logs otherwise under the system and reboots don’t fix it.

It was only after I re-wrote my rules to use actual numbers rather than aliases that I saw progress. Suddenly the Ring devices woke up one by one, updated their firmware, and chugged along happily. DNS handshakes in the captures were now getting responses as intended from my DNS server.

So something about the Alias function in my firewall no longer works correctly and I’ll be submitting a bug report to the developer. Thank you for your guidance! Although it wasn’t the direct solution, it gave me a step in the right direction to find the root of the issue regardless.

1 Like

@TheDaoistTech Thanks for sharing what you learned and I’m glad you were able to get it resolved and get all your Ring devices back up and running. This could help other neighbors who might run into a similar concern with their own networks or help lead them towards a solution. :slight_smile: