Alexa "Sorry, something went wrong..." when loading recent events?

I’m hoping someone can help me with this most odd problem I’m having with my Alexa integration to Ring. I’ll start by saying that I’m having no problems with any of my Ring devices/cameras/security system–everything works fine.

I have my Ring account linked to Alexa, and the Ring skill for the most part works perfect. However, if I say “Alexa, show me the most recent event from the Driveway” Alexa will reply with _“Searching clips for Driveway…sorry, something went wrong.” _ If I then ask a 2nd time, Alexa will again say “Searching clips for Driveway…” but then immediately play the clip fine and without issue.

This behavior is the same every and any time: I always have to ask twice to review the most recent clip from any of my 6 Ring cameras. In contrast, Live View consistently works fine the first time, every time, along with Alexa routines that I also have setup that relate to Ring. Finally, when my doorbell is pressed, Live View auto-loads on my Echo Show. I have an Echo Show 8, and a Fire HD tablet, and regardless of the device, I always have to ask twice as it will error the first time with “Sorry, something went wrong.” Literally everything works except for requesting the most recent video from any camera.

I’ve tried un-linking/disabling the Ring skill, rebooting my devices, and re-linking/enabling the Ring skill. Nothing has worked to resolve this. This ultimately has to be something with the integration, and is not device specific.

Any advice is appreciated!


I now have a support ticket open with Amazon on this and will reply back if anything of value is learned…

I’ve since changed my Ring email to match my Amazon email address. This requirement of having your Ring email match your Amazon email should be communicated better. Functionality of the Ring Skill is limited if the emails don’t match. Motion announcements now work from the Echo Show, which I had hoped would also fix the playback problem, but didn’t.

I’ve exhausted all other possibilities and the above problem still exists: the most recent videos will not play on first request on my Echo Show 8, Show 5, or Fire tablet. Only if I ask a 2nd time will the video play. My Firestick is unaffected by the problem, though, and everything works correctly with it.

I’ve enabled SSID broadcasting on my network (normally hidden). I’ve moved my Show 8 temporarily to an iPhone hotspot. I’ve disabled and re-enabled the Ring Skill countless times. I’ve removed all Ring cameras from Alexa then allowing them to be re-discovered. The end result is the same regardless of these variables. Everything works fine with the Ring Skill except reviewing recent videos, and the problem occurs on 3 of 4 Alexa devices.

The only condition I’ve found where playback works on the first try is if the motion alert is ‘answered’ in the Ring app (resulting in a shorter video than 1 minute or so). All Alexa devices will replay ‘answered’ motion events fine, and on the first request. All ‘unanswered’ motion events will not play unless you ask Alexa twice.

1 Like

have you heard anything back on this yet?