Alexa skill goes berserk

This morning I used the alarm keypad to disable the overnight home setting.

As soon as I did it, the alarm immediately went back to the 30 second countdown to home.

Weird. Tried over and over, the same thing kept happening.

I realized after a while that my Echo device was making a comment about switching to home mode.

I tried using the Echo skill to set the alarm to disabled, which I often do. It asked for my code, I gave it, but it immediately switched back to the 30 second home countdown.

Finally I gave up and just disabled the skill. At that point I was able to use the keypad to disable the alarm.

I can manage my Ring alarm system using just the app and the keypad just fine, so the Echo skill is not necessarily a big deal. But it is kind of weird that it broke in this reather spectacular fashion.

Has anyone else seen this?

Hi @snorkelman. I’d suggest checking out our Help Center Article here on what to do if your Ring and Alexa features stop working properly. I would recommend trying the troubleshooting steps listed there to see if you can get the skill working as expected again. If this concern does persist, you can also reach out to our support team or Alexa’s support team as well. I hope this helps! :slight_smile: