Alex has wrong camera names

I setup my ring cameras with the default names and connected them to alexa. they all connected as “upstairs” as that is what i seleceted when i was prompted in the ring wizard. after they were synced i realized i was not able to view them on my alexa show because they all had the same name.

so i went into the ring acocunt and changed them.

now on my phone, in the ring app (and the website) they are labeled cam 1 / cam 2 / cam 3.

in alexa on my phone they show up as cam 1 / cam 2 / cam 3.

on my alexa show if i say “alexa show me cam 2”, she replies with “did you mean upstairs?”

and then does nothing.

I have disabled / enabled ring on my alexa app
I have disabled the app, deleted the devices, re enabled the app, re synced.

still my show says “did you mean upstairs?” no matter what cam i ask for.

I have factory reset the show as well.

I am at a loss. This Alexa show is 3hrs old and is pissing me off.

Anyone?

i have waited a day to see if maybe if the link would refresh … but no.

I say “computer, show me cam 1”
she says "did you mean upstairs?

upstairs camera has been renamed cam 1.

grr

Here’s all the commands for Alexa. https://support.ring.com/hc/en-us/articles/360031246432-Using-Alexa-to-control-your-Ring-Doorbell-or-Security-Camera-
If you change “cam 1” back to Upstairs does it work? Maybe try naming your cameras after locations and Alexa will comprehend better. Make no mistakes, Alexa understands a bit, but not everything.

1 Like

no if i change one of the cams back to “upstairs” she then says

“there are more than one camera named upstairs, please rename your cameras and re run discovery”

which does nothing…

thought I would give you an update.

I removed the amazon account from the Alexa app on my phone
removed Alexa app from phone
re installed app
re connected to amazon account
removed skill ring
removed 3 camera devices from Alexa device list
re enabled skill
re discovered camera’s
setup the cameras up

i can now say “computer, show me camera 2” and it works. … yay!!

2 Likes

Hi @Lamplyghter. I’m glad to hear that you figured this out. Thank you for sharing how you did it!