Activate mode from IFTTT

Please add option for IFTTT to active modes based on another IFTTT trigger

Like

If smartbutton “on” (smartthings) , then active “Away”

Don’t know if this is already possible but not enabled in IFTTT?

34 Likes

Yes it will be great ! Using ring with home automation is a reel need… please add ifttt compatibility to change modes !

Yes, The same is needed with homeassistant to update modes with a timer, since this capability is not baked in and we forget to update the mode manually.

Absolutely agree. I’m keen to be able to build an alexa routine like follows. “Alexa - arm ring” and have IFTTT change my Ring Camera mode to away. We can’t get the Ring security alarm systems in New Zealand, so unable to integrate Ring with the Alexa Guard features.

Alternatively if Ring and Alexa could integrate the ring cameras into Alex Guard that would be even better. No need for IFTTT.

Absolutely needed. I often forget at night to change mode back to Home from Disarm. Would be helpful if could trigger the change on time of day within IFTTT.

Just came here to see if this had been solved. Love the new modes, but also want it to know when myself and my wife have left the property and set to Away automatically, or when either of us has returned and set to Home automatically.

If you can’t give us native geolocation from the app, then at least expose the new modes so we can do this via IFTTT.

Thanks!

Nothing change in 3 months… Really dispointed…

Quite disappointing that we cannot automate our security system.

If you can’t sort this at least set it up so that you can set a schedule for it to Arm or Disarm.

This is the first thing I was searching for when I activated modes. I mean who does not forget to change modes when going out or coming in?

Modes is almost useless to me without native geolocation or IFTTT support.

Hi there

Ever so slightly off-topic but I’m using iOS 14 on my iPhone and also run Homebridge to surface the Ring devices on Homekit … and iOS 14 has a lovely set of automations it recommended:

When the first person arrives home, set the Ring system to “Home” mode

When the last person leaves, set the Ring system to “Away” mode

And you can tweak those as you want - both what modes are triggered on arrive and leave, etc, and also what those modes do with Ring.

And it works well!

Thanks @marky_uk if you don’t mind me asking did you buy the Homebridge or create your own? If the latter could you share some details please.

Hiya

Homebridge is free. See https://homebridge.io

I have a Synology DiskStation NAS here already but if you don’t have one I’d advise getting a Raspberry Pi and using one of those, it’s nice and cheap. A quick Google of Raspberry Pi homebridge comes up with loads of options, and this is one of the main ones - https://techtechandmoretech.com/news/homebridge-setup/

Once I’ve set that up, anything I’ve got in my house which isn’t HomeKit compatible is suddenly compatible as you just get the relevant plug-in - the community is so active. I’ve got one for my Dyson fan, Somfy blinds, Deebot vac, you name it.

if you need more help, just ask or DM me and I’ll try and help

Hi again, @marky_uk not sure sure how to DM you so just to update you, I now have a pi running homebridge which all seems to be working great thanks. I have minor issue and that is when the homebridge boots I get this error:

[Ring] Failed to reach Ring server at https://oauth.ring.com/oauth/token. getaddrinfo EAI_AGAIN oauth.ring.com. Trying again in 5 seconds…

This will continue until I go to the plugin’s and click settings on the homebridge-ring v9.6.0 plugin and reboot homebridge. I think I must be missing something in the config which looks like this:

{

"bridge": {

    "name": "Homebridge XXXX",

    "username": "XX:XX:XX:XX:XX:XX",

    "port": 51202,

    "pin": "XXX-X-XXX"

},

"accessories": [],

"platforms": [

    {

        "name": "Config",

        "port": 8581,

        "auth": "form",

        "theme": "orange",

        "tempUnits": "c",

        "lang": "auto",

        "platform": "config"

    },

    {

        "refreshToken": "XXXXXXXXXXXX",

        "alarmOnEntryDelay": false,

        "nightModeBypassFor": "some",

        "platform": "Ring"

    }

]

}

Cheers

P

Google is your friend :slight_smile: https://www.reddit.com/r/homebridge/comments/hbm722/homebridge_ring_failed_to_reach_ring_server_at/

Your Pi cannot see the ring server. Have you setup other plugins without issue? Do you have an aggressive firewall in place? Or DNS/routing issues?

I don’t have Homebridge setup on the Raspberry Pi - I use a Synology DiskStation and a Docker image, and I didn’t get this error.

Did you try going to the site https://oauth.ring.com/oauth/token directly? Can you try opening that URL from the Pi? (does it have a browser or can you curl to it?)

@marky_uk

Thanks for all of your help, finally got it working a treat. It might have cost a little but not only have I got my Ring sorted I also have my Harmony through this one little project I’m sure using the Zero it could have been cheaper but I now have a smaller server to do lots of other things too.

Great stuff and top advice.

Many thanks. :wink:

I have the same Request. Either make it work with IFTTT or have a built in schedule for the modes at least.

Thanks @marky_uk I will try that on my NAS