Acrivated/registered professional monitoring and linked accounts but dashboard on app still says in self monitoring mode?

Acrivated/registered professional monitoring and linked accounts but dashboard on app still says in self monitoring mode?

In your app, select the hamburger menu in the upper left.
Select Settings.
Select Monitoring.
Select Self Monitoring (under Type).
Select Professional Monitoring to turn it on.

Be sure you’ve tested your system before you do so that you don’t unexpectedly activate the alarm.

Did that. There is no option to switch to Ring Protect. It just says "you need Ring Protect for professional monitoring "

Have you gone through the testing phase yet? I believe it’s a week in length.