406 Not Acceptable

Hi Team,

I’m getting 406 Not Acceptable all of a sudden when visiting the ring site. Seems like I’m blacked.

Can someone at Ring confirm?

On cellular my connection is fine.

Alan

Hey @Aseb. Please ensure you do not have a VPN turned on when you are trying to access Ring.com. If you continue to have this concern, try clearing your cache and cookies and trying again. In the event you continue to get this error, please let me know what link you go to that does this, or what you do to on the site to cause this error. In addition, a screenshot of this error message and details on what computer/browser you are accessing this on will help! :slight_smile:

I’m also getting this same error via the API:

Request to https://app.ring.com/rhq/v1/devices/v1/locations failed with status 406.

when I try to authenticate to ring.com to view my camera via the website I get an error stating “Invalid email or password.” That’s a misleading error, but I suspect it’s generated for the same reason as the status 406 error.

I know that my email and password aren’t invalid, because when I try to authenticate via a different computer that’s connected to my work VPN - and therefore using a different source ip address - I am able to autheniticate just fine and view my cameras via the website.

The process I use to access via the API was stuck in a restart loop this morning, so my suspicion is that the restart loop called the ring API too many times in a short period and my IP address has been blacklisted from logging in.

What I’m not able to determine is how long that blacklist will last, or even whether this theory is accurate about being blacklisted. It would be useful if someone here was able to confirm whether this is the case.

Hi @jimcovert! The best next steps is to continue to test while the VPN is disabled or not a factor. Please also try another browser. If your mobile app is able to login and the browser is not, its always good to check for any additional security settings/ apps, or even connection concerns that might prevent the browser from completing this request.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. I hope this helps! :slight_smile:

I was able to sign in after I waiting for the lockout/blacklist period to end. I think it was around 24 hours.

1 Like

Thanks @jimcovert - we’ll get this over to the team to take a further look into for you!

Same problem. It has been 48 hours and continue to receive “Not Acceptable” message. It appears to be that Ring has blacklisted my IP address. In addition to the App not functioning (and cameras not connecting), I am blocked from Ring.com. This is troublesome as a I have 7 Ring cameras. Telephone customer service has been of zero assistance.

1 Like

Hey @JimBobSD. Are you trying to access Ring.com from a web browser with a VPN enabled? Where are you located in (general region is helpful)? Can you please capture a screenshot of this error message you keep receiving, and what steps you take to get this error message? I can look into this further for you!

I already outlined this on the phone with customer support and have already provided screenshots. I have also provided tracert information. This is on Ring’s end. In any event, here’s your answers:

  1. I checked all the Ring.com support options and exhausted them all. I also saw reference to VPNs. I do not use a VPN. I tried all Ring.com suggested options. Yes, I restarted my phone and computer. Yes, I restarted my cable modem and router. Yes, I logged out of the app. Yes, I deleted and reinstalled the app. Yes, I tried to log back in (but when on my home IP address, it will not connect). When I switch to cellular or change my home’s IP address, I am able to connect and do not receive a 406 Not Acceptable message.

  2. This 406 Not Acceptable message occurs across all platforms and all devices. This error occures on Linux, Windows and OS X - tried all three. This also happens on iOS (latest versions) on iPad Pro and iPhone 11 Pro if my home internet is used (with my assigned IP). This happens on Chrome, Internet Explorer, Edge, and Safari browsers. If I switch my IP address, it works. For example, I can use a hotspot on my phone and connect a computer to it. Ring works fine if I am on alternative IP address. The app works fine if I am on alternative IP address.

  3. Is it my cable modem or router? No. I can get a new IP address by removing the router and connecting directly to my cable modem. Once I have that new IP address, I can connect to Ring. My external IP address is assigned to a specific device. While I cannot completely eliminate that my router might be causing the problem, there are no known issues with routers issuing 406 messages. In any event, I also reset all router settings, disabled firewall, disabled IPv6, used Google DNS (8.8.8.8) and disabled all limitations on internet traffic. Nothing changed. The only variable that appears to matter is my external IP address. The only thing that makes sense is that Ring is blocking my IP address or a range of IP addresses.

  4. My provider is Spectrum. They have reported no issues. I spent a bit of time with them on the phone about this to make sure they were not having backbone issues. They say they aren’t.

  5. I am in San Diego.

Screenshots attached.

1 Like

@JimBobSD Thank you a ton for this in-depth information, I really do appreciate you getting back to me with this and the applicable screenshots. I’m getting this escalated with the appropriate teams, but it may be a day or two before I get more information on this concern. If necessary and if we need to follow up further on your personal account, would it be okay if we reached out to your via the email address you use for Community? I’m happy to get this sorted out for you in the best way we can so you can have you back to using Ring as you once were.

Feel free to contact me. I’m adding two more screenshots – as Ring Community has a two screenshot limit per post. Thank you for the help.

@JimBobSD Thank you for those screenshots as a follow up! I’ve gotten this over to my teams who are still taking a look into it, but will provide me an update tomorrow. I will email you from your email on file for your account here tomorrow, but please feel free to reply here if you don’t hear from me via email by end of day. Again, happy to help. :slight_smile:

After about a week, it looks like I am finally unblocked.

@JimBobSD Thanks for the follow up here! Happy to hear this is working for you now. I did get more information back from my team this morning which I will be emailing you shortly on. :slight_smile:

I just had the exact same problem on my IPhone. It would not log in and when Ring sent me a password reset link, the browser on my IPhone said error 406 Not Acceptable. I checked to make sure Nord VPN was not running and it appeared that is was not, but when I went into settings - VPN, it showed that it was, in fact running despite rebooting my IPhone. The answer was to go into Settings - VPN - Nord Vpn - press the i for more information and then Delete the VPN.

When I then tried to login to Ring - It worked!!

1 Like

I have been experiencing this same issue in the past few days - also on Spectrum in San Diego. It looks like my IP (75.80.47.151) was banned from authenticating, with an instant “406 Not Acceptable” server error response in the browser console - I could not authenticate using the browser, or Android apps on 2 different Android devices. If I switched to mobile data on my phone, everything worked again. Everything also worked if I enabled a VPN (which obviously changed the IP address the Ring servers saw me coming from as), either on my phone or home computer, but as long as I was going through Spectrum, I could not log in.

Once logged in however, the apps and the website continued to work fine, even after switching back to my ISP, it was only the initial authentication that appears to be blocked.

After a few hours of troubleshooting (restarting everything, disabling security features, etc.), and an hour on the phone with Ring support last night, I finally tried to force my router to obtain a new IP address from Spectrum, and once that happened, everything started working again, I can now authenticate on both the website and Android apps even when going through Spectrum, only now with a different/new IP.

It really looks like Ring is blocking certain specific IP’s from authenticating for some reason on their end.

2 Likes

I just hit the same issue today right after updating my ring app via the App Store (iOS 13.6). After working with T2 support, seems like I hit the same issues others did, and my IP was shadow banned. I’m able to access everything ring when I’m on a VPN or cellular data. Seems weird that they’d ban IPs and not send any notifications, let alone now give support reps the ability to remove the ban, let alone tell you why your IP was banned. I didn’t attempt logging in, just opened the app after the ring app update and ran into the errors associated with the 406. Hopefully I’ll have access restored tomorrow.

And this is exactly why I could not connect to my ring cameras via WiFi. Absolutely nothing to do with my internal WiFi and absolutely nothing to do with my cable modem and absolutely nothing to do with Comcast. This issue has been happening to me randomly for the past couple months. Everything has been working for the last two weeks. It is currently not working and I randomly tried logging into ring.com and got the 406 error. Now it makes sense. All we need now is for Ring to get their act together!!!

1 Like

Did anyone at Ring ever figure this out or do we just muddle along with our apps working one day and not working then next???

1 Like

Sorry to hear about this, neighbors! If you are receiving a 406 error, try refreshing your connection and allow the ring server some time to process the request. As multiple requests to a website domain can create this error, sometimes this can be fixed by waiting 24 hours.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.