30-second recording limit makes this product half useless

I’m extremely unsatisfied with my Ring products. I understand the desire to preserve battery by limiting recording to 30 seconds, but *I* bought this device and *I* bought extra batteries. Battery life shoul be *my* problem to manage and not your problem to manage for me.

30 seconds is wholly inadequate. It is the easiest thing to game. 1) trigger motion detection with back to camera. 2) wait off camera. 3) do your dirty deed during the recording cooldown.

This product is almost worthless with such a limitation. I’m thoroughly disappointed, and certainly actively discourage this product to anyone. I’d rather give up remote monitoring and have a proper alway-on DVR-based camera system. I wish I had gone that route rather than spending so much money with Ring.

To make things far worse, I can only get a live view about 50% of the time, getting a failure to connect error messag intermittenly the rest of the time. A call to support correct neither issue.

I’ve put up with these prolems for a long while now, and I’m ready to chuck these off the roof. Oh well, buyer beware, i guess.

Yes @jelder23 it is true that battery powered Ring cameras record in 30 second “batches” (most hardwired cams record up to 1 minute long “batches”). Battery cams are set to a default Motion-Frequency setting that will limit activated recordings. Adjust your “Motion Frequency” to “Frequent”. Since battery-life can be rapidly depleted, the default setting on your cam is set so it doesn’t capture every event. You can change that by selecting the “Devices” from the main menu > select your cam > Motion Settings > Motion Frequency > then select “Frequent” (note: the Motion-Frequency option is often missed, because you may have to scroll down below Motion-Schedule). This way, every motion should activate the start of a new “batch” recording, and when the 30 seconds it finished, then there will be a slight delay and it should start recording another new “batch”, if it still detects motion.

If your Cam detection is missing or producing a late activations, it might be another setting on your phone app. Select “Devices” from the main menu > select your doorbell > Motion Settings > Motion Verification (or “People Only Mode” on some Ring devices). If toggled ON, the camera tries to make activations more accurate using algorithms to determine human-motion, and will not activate for every event. The algorithms-processing-time might delay the cam for 1-2 seconds. While these are toggled ON, it can screen out non-people motion, such as animals, cars, or tree movement, etc. and miss/delay some motion-events. Also, these algorithms are used to determine if it is a human-motion by looking at both body heat coupled with movement . . . and with hot summer daytime temperatures, these algorithms can have difficulty detecting body-heat movement against low-contrasting hot-backgrounds. But the algorithms should be fine during summer night-times. You could try to Deselect “People Only Mode” / “Motion Verification.” Toggled OFF, you’ll detect more motion, but then you may get unwanted, annoying non-people activations.

-Also, initially adjust “Motion Settings” to set MAX on Motion Sensitivity" (with “People Only Mode” toggled off). You will pick up more motion since it is not screening for people only. With “People Only Mode” toggled ON, you will not be able to adjust “Motion Sensitivity.” Then gradually tweak back from MAX to a setting that sufficiently cuts down on unwanted non-people detections.

Of course, tweaking these settings will shorten your battery life.

As for your issue “_ only get a live view about 50% of the time” _that definitely sounds like a Wi-Fi related issue. Ring Video requires a much higher Wi-Fi data-stream connection, and if not, you may encounter problems (slow or no “Live View” connections, Black-screen videos, etc.). A strong signal connection doesn’t necessarily mean a good data connection. I too was having intermittent/delayed Live View connection issues with one of my cameras. Now, my Live View connection is established rapidly every time! In my case, even with a good RSSI (a low value of 48) signal strength number (displayed on “Device Health”), my issue was the Wi-Fi path of the Video data-stream between the router and my camera (was passing through a double-brick fireplace with a metal chain grating in front of it). This path degraded my data-stream. Since I couldn’t move my router nor camera (to improve Wi-Fi reception or path), a Wi-Fi ‘repeater’ type-device enabled me to have the signal path “go around” the brick/metal grate. Any good 2.4 GHz Wi-Fi repeater, placed about half the distance between your Router and cam should help both with your poor RSSI strength and choosing a low-density-obstruction path (or the Ring Chime Pro, which I did purchase which solved my signal-path interference issues).

Check your Wi-Fi router. If you have two SSIDs, you will need to find out which one is 2.4 and which one is 5, and then you will connect your Ring device to the SSID for the 2.4 Ghz network. In my experience, Ring high-data-stream video does NOT do well competing with other Wi-Fi devices for bandwidth of 2.4GHz. Since my router is both Wi-Fi 2.4GHZ and 5Ghz, I moved as many of my other devices (that were 5GHz capable) to only use the 5GHz band, thereby reducing the competition for the Ring Cams. I reconfigured my dual-band router’s into two separate SSID log-in names. I named the 2.4GHz band to “2WireXXX” and named the 5GHZ band “2WireXXX 5G” leaving both with the same password. Then my other Wi-Fi devices that could use 5GHz, I used “forget this network” and then logged them onto only the “2WireXXX 5G”.

You might want to look into modifying your 2.4GHz Channel Selection too, to minimize interference issues created by neighbor’s routers or signal-generating devices in your home (microwaves, electric motors, etc.). In the router’s default “Auto” mode, routers often pick a mainly from commonly-used channels in Auto Mode (Ch 1, Ch 6, Ch 11). But accessing my router’s configuration through my PC browser and using a downloaded App on my Window’s PC (Wifi Analyzer and Scanner), I configure my router not to use its Auto Channel Selection Mode, and rather stay on the 2.4GHz channel of my choice . There are 11 channels (1 thru 11) to choose from. In my case, I found that Ch 4, which is in between the typically used channels, gave me the strongest signal and lowest interference, according to the Analyzer App. This channel did reduce the Wi-Fi interference I was getting from my neighbor’s routers. I also did noticed an improvement on my Ring cameras connection speed too.

If you still have issues, re-post here (someone might have another solution), or try searching through the Ring On-line Support, such as:

https://support.ring.com/hc/en-us/articles/360023439472-Fixing-Black-Video-Errors-by-Adjusting-Your-Router

https://support.ring.com/hc/en-us/articles/360023556192-Fixing-Poor-Audio-Video-Quality-by-Adjusting-Your-Router

Or you can call Ring Support by telephone:

https://support.ring.com/hc/en-us/articles/360036196372-Get-in-Touch

I hope this helps you :slight_smile: