3 Beep error on Mac when using live view

I have a 2018 MacMini running macOS Catalina version 10.15.6. When ever I try to view a ring camera in the ring app using live view after 30 seconds the computer will put out three loud beeps and the live view will go away, sort of like a crash of just the live view window. The main ring app stays active. I have uninstalled and reinstalled the ring app to no avail. Thinking it might be the OS software, I installed a clean copy of MacOS on a separate drive and tried that way and got the same response. Thinking it might be a hardware memory issue I ran the apple diagnostics which showed no issues. I checked the log files and could find nothing of note. This computer does have the T2 chip, I was wondering if that might be an issue.

I do run windows on this computer under a VR drive with Parallels and the ring app works exactly as it should using the same hardware and live view works perfectly. I am stumped as to what is wrong?""

Hi @Talluton. Thank you for sharing details on what steps you’e tried for this concern already. If possible, can you please share a short video or recording of the beeping and then crashing that you’re experiencing with the Live View? I’d like to take a look and see what I can recommend. When attaching this video, you will need to compress the MP4 file into a ZIP file, as ZIP files can be attached to your reply and not MP4s. In addition, you can upload this video elsewhere, such as YouTube, and then share the link to the video in your reply. :slight_smile:

I have attached a video of the error with the three beeps. Any suggestions would be helpful. I am particularly confused that I get no error when running ring inside of a VR session of windows on the Mac

Did you ever figure this out? Having the same issue.

No, It started working a few days ago. I believe that there was a recent Ring update. Not sure if that had anything to do with it or not.

I just downloaded the app and noticed this so I should have the most recent update. Not sure whats causing it but its extremely annoying.

One, thing that had occurred to me. I have several Mac’s that are running Catalina. All of the older Mac’s worked great. No problems with Live View on the Ring App. The one with the problem is a new Mac Mini. It has a T2 security chip, the others don’t. Its a mystery to me, and I don’t know why it corrected itself.

I posted a same issue. In my case this also accurs the app on a iPhone 11 Pro Max…

Its happening on my 2019 Mac Mini, 2018 Macbook Pro and not my 11 Pro Max.

Is there any update to this?

I haven’t heard anything at all.

Hey neighbors! It’s possible that whatever you have as your main audio output device set to as your default can still have some sound pushed through to it and may not be truly muted. The three loud beeps that you are hearing are in reference to the Live View timing out and turning itself off. This is by design, as the Live View is restricted to a max of 10 minutes of live streaming, and then we must alert you that it has been disconnected by the announcement of those beeps. For the feedback on having this turned off and not having these beeps, I’ve passed on this feedback to the rest of the team for you! I appreciate the video example, as I was able to share that with my team.

I would recommend going under your Ring app on the Mac > Ring > Preferences at the top > and then changing your audio output device to not be default, but instead put it to whatever speakers/system that is hooked up that you know has the sound turned off (like speakers that are off), therefore that it does not play through the Mac’s default, built in speakers. I hope this helps out and thank you again for your feedback!


The only problem with your reply is that mine went off at 30 seconds every time. Not ten minutes. The audio was set to the speakers and not the mac internal speaker and the sound came from the MacMini not attached speakers. Also, when live view cuts out at the ten minute time the live view window stays up, it just cuts live feed. In the example I gave you on the video, the whole window quits upon the error chime.

The problem on my Mac Mini did self correct a few weeks back. Also, on all my devices I do not get a audible when live feed cuts off at ten minutes.


That is correct however we are being timed out at 30 seconds using Macs.

Thanks for the clarification! Can you please let me know which version of the Ring App you’re running? You’ll go to your Applications folder, right-click the Ring icon and tap on Get Info and it will be under General > Version. I’ll pass this over to my team, as the app version will help them look into this further.

Caitlyn, my version is 2.8.1 (801)