2nd Generation Keypad not working

Bought the Ring Alarm Bundle with the extra Keypad. After a month, the keypad was not working ?! (nil lights and nil response when pressing the keypad) Tried different ways to fix the problem by charging the keypad, reset with the pin and remove the keypad from the base system …still in vain. Eventually, Customer Service admitted the keypad was a fault device.

Not impressed with the fact that there is not enough online information or support to show me how to detect / diagnosis the problem. Not impressed with the quality of the devise. Hopefully, the alarm system could last for couple of years.

Same thing happened to me. It’s moments like these when you realize how “junky” these devices are. I have a bigger home & so like 20 sensors, 2 keypads, etc & this same thing happened w/a window sensor. Not enough info online, So frustrating!

Hi @DreRing. You are able to see all of the information about your Ring Alarm devices in the Ring app. This will let you things such as battery level and offline status. If you are noticing that your Keypad is frequently offline, you may need to move your Range Extender to a new location to improve the connectivity. I hope this helps.

Rechecked settings in Ring app and noticed that the Led slide bar was all the way left (least brightness). I remember now my wife complained the light was to bright and keeping her awake.

Green light for battery status is still no on.

1 Like