2020 release battery doorbell offline

I’m having some difficulties and I hope someone can help please.
I’ve had my doorbell for 3 months and it’s been great and always worked fine. I charged it for the first time (since original charge) three days ago and since then it’s stopped working properly. The app shows it is at 100% and the blue light stayed static but it’s behaving as if the battery is dead. The WiFi is fine. I have tried resetting but the white light never comes on. I plugged it in and it started working, the blue light flashed briefly and then became static so I put it back. After this it worked for about 30 minutes and stopped again. Does this sound familiar to anyone? Thanks.

Hi @user4250. Try resetting the Doorbell by holding down the setup button for at least 20 seconds. After the reset is done, walk your Doorbell through a new setup in the Ring App with the steps under Set Up a Device. Then try activating the Live View or ringing the Doorbell to trigger a test event and see if everything is working properly.